summaryrefslogtreecommitdiffstats
path: root/rpc/xdr/gen/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@inai.de>2017-12-14 19:43:43 +0100
committerNiels de Vos <ndevos@redhat.com>2018-01-26 12:58:03 +0000
commitc3647b747af88e40334e927dafdbf88154b308f0 (patch)
treee57c6684dea96aec8f9517fbf40d3b9e1599328c /rpc/xdr/gen/Makefile.am
parent1a519f4bf960c6aafecfb189e8ec8b153abcf6ce (diff)
build: restore ability to control verbosity settings
`make V=1` is broken — no commands are printed whatsoever. At the same time, `make V=0` *also* is broken in that no summary lines ("CC  foo.o") are printed, either. Kill the annoying hardcoded --quiet in configure.ac, since it seems to override everything that automake offers. Change-Id: I377c0e0469619a33586afb4a93dde6d241e7bc21 Fixes: #381 BUG: 1539023 Original-author: Jan Engelhardt <jengelh@inai.de> Signed-off-by: Niels de Vos <ndevos@redhat.com> [ndevos: silence rpc/xdr/gen rpgcen]
Diffstat (limited to 'rpc/xdr/gen/Makefile.am')
-rw-r--r--rpc/xdr/gen/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/rpc/xdr/gen/Makefile.am b/rpc/xdr/gen/Makefile.am
index c253e38275d..df379b80130 100644
--- a/rpc/xdr/gen/Makefile.am
+++ b/rpc/xdr/gen/Makefile.am
@@ -18,14 +18,14 @@ xdrdst=$(top_builddir)/rpc/xdr/src
# could use a '-' (i.e. -@rpcgen ...) and suffer with noisy warnings
# in the build. Or we do this crufty thing instead.
$(XDRSOURCES): $(XDRGENFILES)
- if [ ! -e $(xdrdst)/$@ -o $(@:.c=.x) -nt $(xdrdst)/$@ ]; then \
+ @if [ ! -e $(xdrdst)/$@ -o $(@:.c=.x) -nt $(xdrdst)/$@ ]; then \
rpcgen -c -o $(xdrdst)/$@ $(@:.c=.x) ;\
fi
# d*mn sed in netbsd6 doesn't do -i (inline)
# (why are we still running smoke on netbsd6 and not netbsd7?)
$(XDRHEADERS): $(XDRGENFILES)
- if [ ! -e $(xdrdst)/$@ -o $(@:.h=.x) -nt $(xdrdst)/$@ ]; then \
+ @if [ ! -e $(xdrdst)/$@ -o $(@:.h=.x) -nt $(xdrdst)/$@ ]; then \
rpcgen -h -o $(@:.h=.tmp) $(@:.h=.x) && \
sed -e '/#ifndef/ s/-/_/g' -e '/#define/ s/-/_/g' \
-e '/#endif/ s/-/_/' -e 's/TMP_/H_/g' \