summaryrefslogtreecommitdiffstats
path: root/rpc/xdr/gen/Makefile.am
diff options
context:
space:
mode:
authorNiels de Vos <ndevos@redhat.com>2017-10-10 13:23:50 +0200
committerJeff Darcy <jeff@pl.atyp.us>2017-10-13 16:28:55 +0000
commita413c6353dbfff5221ea020ff8e1475d5ee17a81 (patch)
treec09014d0d29fe99edff678c5861da13e1986febb /rpc/xdr/gen/Makefile.am
parentc64fd0d4b0ef313bb44aae68a376ec0c9ee8657a (diff)
build: make it possible to build cleanly 2x in a row
'make clean' does not cleanup everything, and some of the files get cleaned too eagerly. Several files are being packaged in a 'make dist' tarball, that get rebuild each time anyway. Specifically, this change prevents - libglusterfs/src/generator.pyc from laying around - keeping rpc/xdr/gen/*.x symlinks - modifying tests/basic/{fuse,gfapi}/Makefile each run - including tests/env.rc and events/src/eventtypes.py in the tarball Change-Id: I774dd1abf3a9d3b6a89b938cf6ee7d7792c59a82 BUG: 1501317 Reported-by: Patrick Matthäi <pmatthaei@debian.org> Signed-off-by: Niels de Vos <ndevos@redhat.com>
Diffstat (limited to 'rpc/xdr/gen/Makefile.am')
-rw-r--r--rpc/xdr/gen/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/rpc/xdr/gen/Makefile.am b/rpc/xdr/gen/Makefile.am
index 6cffca4c3ac..b1c8e9333d6 100644
--- a/rpc/xdr/gen/Makefile.am
+++ b/rpc/xdr/gen/Makefile.am
@@ -4,7 +4,7 @@ XDRGENFILES = glusterfs3-xdr.x cli1-xdr.x nlm4-xdr.x nsm-xdr.x \
XDRHEADERS = $(XDRGENFILES:.x=.h)
XDRSOURCES = $(XDRGENFILES:.x=.c)
-CLEANFILES = $(XDRSOURCES) $(XDRHEADERS)
+CLEANFILES = $(XDRSOURCES) $(XDRHEADERS) $(XDRGENFILES)
# trick automake into doing BUILT_SOURCES magic
BUILT_SOURCES = $(XDRHEADERS) $(XDRSOURCES)