summaryrefslogtreecommitdiffstats
path: root/rpc/rpc-transport/socket/src/Makefile.am
diff options
context:
space:
mode:
authorVijaikumar M <vmallika@redhat.com>2014-05-23 14:42:08 +0530
committerRaghavendra G <rgowdapp@redhat.com>2014-06-05 10:11:45 -0700
commit42b956971c47fd0708cbbd17ce8c78c2ed79bfba (patch)
treec8056e730ff7277a6a323aad85ac8874862e4099 /rpc/rpc-transport/socket/src/Makefile.am
parenta89e35727e3a9a7226c7a16479935b7109b11663 (diff)
glusterd: Handle rpc_connect failure in the event handler
Currently rpc_connect calls the notification function on failure in the same thread, glusterd notification holds the big_lock and hence big_lock is released before rpc_connect In snapshot creation, releasing the big-lock before completeing operation can cause problem like deadlock or memory corruption. Bricks are started as part of snapshot created operation. brick_start releases the big_lock when doing brick_connect and this might cause glusterd crash. There is a similar issue in bug# 1088355. Solution is let the event handler handle the failure than doing it in the rpc_connect. Change-Id: I088d44092ce845a07516c1d67abd02b220e08b38 BUG: 1101507 Signed-off-by: Vijaikumar M <vmallika@redhat.com> Reviewed-on: http://review.gluster.org/7843 Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com> Reviewed-by: Jeff Darcy <jdarcy@redhat.com> Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Raghavendra G <rgowdapp@redhat.com> Tested-by: Raghavendra G <rgowdapp@redhat.com>
Diffstat (limited to 'rpc/rpc-transport/socket/src/Makefile.am')
-rw-r--r--rpc/rpc-transport/socket/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/rpc/rpc-transport/socket/src/Makefile.am b/rpc/rpc-transport/socket/src/Makefile.am
index 71e6ed6ff4a..5e909aceac8 100644
--- a/rpc/rpc-transport/socket/src/Makefile.am
+++ b/rpc/rpc-transport/socket/src/Makefile.am
@@ -1,4 +1,4 @@
-noinst_HEADERS = socket.h name.h
+noinst_HEADERS = socket.h name.h socket-mem-types.h
rpctransport_LTLIBRARIES = socket.la
rpctransportdir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/rpc-transport