summaryrefslogtreecommitdiffstats
path: root/libglusterfs/src/Makefile.am
diff options
context:
space:
mode:
authorAravinda VK <avishwan@redhat.com>2016-08-18 14:51:44 +0530
committerAravinda VK <avishwan@redhat.com>2016-08-24 01:23:06 -0700
commitd1aa35c3619847922e092b7dbfb201bceea8fa33 (patch)
treea2f936c481b9201b63a4bf77f1346946f69cb8a3 /libglusterfs/src/Makefile.am
parent4aa52061a51b97c4f865b402f977b3b43f5471a7 (diff)
eventsapi: Fix disable-events issue
Events related sources are not loaded in libglusterfs when configure is run with --disable-events option. Due to this every call of gf_event should be guarded with USE_EVENTS macro. To prevent this, USE_EVENTS macro was included in events.c itself(Patch #15054) Instead of disabling building entire directory "events", selectively disabled the code. So that constants and empty function gf_event is exposed. Code will not fail even if gf_event is called when events is disabled. BUG: 1368042 Change-Id: Ia6abfe9c1e46a7640c4d8ff5ccf0e9c30c87f928 Signed-off-by: Aravinda VK <avishwan@redhat.com> Reviewed-on: http://review.gluster.org/15198 Smoke: Gluster Build System <jenkins@build.gluster.org> Reviewed-by: Niels de Vos <ndevos@redhat.com> CentOS-regression: Gluster Build System <jenkins@build.gluster.org> NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Diffstat (limited to 'libglusterfs/src/Makefile.am')
-rw-r--r--libglusterfs/src/Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/libglusterfs/src/Makefile.am b/libglusterfs/src/Makefile.am
index 1fdd5a70fa4..d1ffbad5cc7 100644
--- a/libglusterfs/src/Makefile.am
+++ b/libglusterfs/src/Makefile.am
@@ -37,7 +37,7 @@ libglusterfs_la_SOURCES = dict.c xlator.c logging.c \
nodist_libglusterfs_la_SOURCES = y.tab.c graph.lex.c defaults.c
nodist_libglusterfs_la_HEADERS = y.tab.h glusterfs-fops.h
-BUILT_SOURCES = graph.lex.c defaults.c glusterfs-fops.h
+BUILT_SOURCES = graph.lex.c defaults.c glusterfs-fops.h eventtypes.h
libglusterfs_la_HEADERS = common-utils.h defaults.h default-args.h \
dict.h glusterfs.h hashfn.h timespec.h logging.h xlator.h \
@@ -51,7 +51,7 @@ libglusterfs_la_HEADERS = common-utils.h defaults.h default-args.h \
glfs-message-id.h template-component-messages.h strfd.h \
syncop-utils.h parse-utils.h libglusterfs-messages.h tw.h \
lvm-defaults.h quota-common-utils.h rot-buffs.h \
- compat-uuid.h upcall-utils.h throttle-tbf.h
+ compat-uuid.h upcall-utils.h throttle-tbf.h events.h
libglusterfs_ladir = $(includedir)/glusterfs
@@ -71,14 +71,12 @@ libglusterfs_la_SOURCES += $(CONTRIBDIR)/uuid/clear.c \
$(CONTRIBDIR)/uuid/unpack.c
endif
-if BUILD_EVENTS
-BUILT_SOURCES += eventtypes.h
-libglusterfs_la_SOURCES += events.c
-
-libglusterfs_la_HEADERS += events.h eventtypes.h
-eventtypes.h: $(top_srcdir)/events/eventskeygen.py
+eventtypes.h:
$(PYTHON) $(top_srcdir)/events/eventskeygen.py C_HEADER
+
+if BUILD_EVENTS
+libglusterfs_la_SOURCES += events.c
endif
libgfchangelog_HEADERS = changelog.h