summaryrefslogtreecommitdiffstats
path: root/libglusterfs/src/Makefile.am
diff options
context:
space:
mode:
authorKaleb S. KEITHLEY <kkeithle@redhat.com>2015-10-14 11:13:50 -0400
committerNiels de Vos <ndevos@redhat.com>2015-11-16 01:15:04 -0800
commit82e45b87e30ce4ec2ab62c39820951da7a82eddb (patch)
treef74f1763191e4229c762e337e6793785b3c6a0f3 /libglusterfs/src/Makefile.am
parent8ad921e8d61e8b7b1dcd4aaba5d00aafbb55cf2a (diff)
build: install and package header files more conventionally
The current way we install and package header files for the -devel package is a hack. This patch uses more conventional autoconf, libtool, and rpmbuild idioms to package -devel headers and libraries. Change-Id: I63ffb3460f5c12b6b355493bd00824ac9e5354c5 BUG: 1271907 Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com> Reviewed-on: http://review.gluster.org/12360 Tested-by: NetBSD Build System <jenkins@build.gluster.org> Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Niels de Vos <ndevos@redhat.com>
Diffstat (limited to 'libglusterfs/src/Makefile.am')
-rw-r--r--libglusterfs/src/Makefile.am34
1 files changed, 19 insertions, 15 deletions
diff --git a/libglusterfs/src/Makefile.am b/libglusterfs/src/Makefile.am
index 904da328bea..1b3a5572c8b 100644
--- a/libglusterfs/src/Makefile.am
+++ b/libglusterfs/src/Makefile.am
@@ -36,23 +36,27 @@ nodist_libglusterfs_la_SOURCES = y.tab.c graph.lex.c defaults.c
BUILT_SOURCES = graph.lex.c defaults.c
-noinst_HEADERS = common-utils.h defaults.h default-args.h dict.h glusterfs.h \
- hashfn.h timespec.h \
- logging.h xlator.h stack.h timer.h list.h inode.h call-stub.h compat.h \
- fd.h revision.h compat-errno.h event.h mem-pool.h byte-order.h \
+libglusterfs_la_HEADERS = common-utils.h defaults.h default-args.h \
+ dict.h glusterfs.h hashfn.h timespec.h logging.h xlator.h \
+ stack.h timer.h list.h inode.h call-stub.h compat.h fd.h \
+ revision.h compat-errno.h event.h mem-pool.h byte-order.h \
gf-dirent.h locking.h syscall.h iobuf.h globals.h statedump.h \
- checksum.h daemon.h $(CONTRIBDIR)/rbtree/rb.h store.h\
- rbthash.h iatt.h latency.h mem-types.h syncop.h cluster-syncop.h \
- graph-utils.h trie.h refcount.h \
- run.h options.h lkowner.h fd-lk.h circ-buff.h event-history.h \
- gidcache.h client_t.h glusterfs-acl.h glfs-message-id.h \
- template-component-messages.h strfd.h syncop-utils.h parse-utils.h \
- libglusterfs-messages.h ctr-messages.h \
- $(CONTRIBDIR)/mount/mntent_compat.h lvm-defaults.h \
+ checksum.h daemon.h store.h rbthash.h iatt.h latency.h \
+ mem-types.h syncop.h cluster-syncop.h graph-utils.h trie.h \
+ refcount.h run.h options.h lkowner.h fd-lk.h circ-buff.h \
+ event-history.h gidcache.h client_t.h glusterfs-acl.h \
+ glfs-message-id.h template-component-messages.h strfd.h \
+ syncop-utils.h parse-utils.h libglusterfs-messages.h tw.h \
+ ctr-messages.h lvm-defaults.h quota-common-utils.h rot-buffs.h \
+ compat-uuid.h upcall-utils.h
+
+libglusterfs_ladir = $(includedir)/glusterfs
+
+noinst_HEADERS = unittest/unittest.h \
+ $(CONTRIBDIR)/rbtree/rb.h \
+ $(CONTRIBDIR)/mount/mntent_compat.h \
$(CONTRIBDIR)/libexecinfo/execinfo_compat.h \
- unittest/unittest.h quota-common-utils.h rot-buffs.h \
- $(CONTRIBDIR)/timer-wheel/timer-wheel.h compat-uuid.h \
- tw.h upcall-utils.h
+ $(CONTRIBDIR)/timer-wheel/timer-wheel.h
if !HAVE_LIBUUID
# FIXME: unbundle libuuid, see compat-uuid.h.