summaryrefslogtreecommitdiffstats
path: root/heal/src/Makefile.am
diff options
context:
space:
mode:
authorAnuradha <atalur@redhat.com>2014-12-12 12:56:22 +0530
committerPranith Kumar Karampuri <pkarampu@redhat.com>2014-12-23 07:09:23 -0800
commit85427a23c238499137cbfaafdb7b6ad27f67506a (patch)
tree6b8c5c7e802b2080d4b4e7299f1f89034538039d /heal/src/Makefile.am
parentf3df93783d8c817722e086b14b97fa6bc9d0fce8 (diff)
cluster/afr : Change in volume heal info command
gluster volume heal <volname> info command will now also display if the files listed (in the output of the command) are in split-brain or possibly being healed. This patch also fixes build warning that occurs. Change-Id: I1fc92e62137f23b2b9ddf6e05819cee6230741d1 BUG: 1163804 Signed-off-by: Anuradha <atalur@redhat.com> Reviewed-on: http://review.gluster.org/9119 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com> Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Diffstat (limited to 'heal/src/Makefile.am')
-rw-r--r--heal/src/Makefile.am5
1 files changed, 0 insertions, 5 deletions
diff --git a/heal/src/Makefile.am b/heal/src/Makefile.am
index b4089278607..80be3d443cf 100644
--- a/heal/src/Makefile.am
+++ b/heal/src/Makefile.am
@@ -6,14 +6,12 @@ glfsheal_LDADD = $(top_builddir)/libglusterfs/src/libglusterfs.la $(GF_LDADD)\
$(RLLIBS) $(top_builddir)/rpc/xdr/src/libgfxdr.la \
$(top_builddir)/rpc/rpc-lib/src/libgfrpc.la \
$(top_builddir)/api/src/libgfapi.la \
- $(top_builddir)/xlators/cluster/afr/src/afr.la \
$(GF_GLUSTERFS_LIBS) $(XML_LIBS)
glfsheal_LDFLAGS = $(GF_LDFLAGS)
AM_CPPFLAGS = $(GF_CPPFLAGS) \
-I$(top_srcdir)/xlators/lib/src\
- -I$(top_srcdir)/xlators/cluster/afr/src\
-I$(top_srcdir)/libglusterfs/src -I$(top_srcdir)/rpc/rpc-lib/src\
-I$(top_srcdir)/rpc/xdr/src\
-I$(top_srcdir)/api/src\
@@ -30,6 +28,3 @@ CLEANFILES =
$(top_builddir)/libglusterfs/src/libglusterfs.la:
$(MAKE) -C $(top_builddir)/libglusterfs/src/ all
-
-$(top_builddir)/xlators/cluster/afr/src/afr.la:
- $(MAKE) -C $(top_builddir)/xlators/cluster/afr/src/ all