summaryrefslogtreecommitdiffstats
path: root/heal/src/Makefile.am
diff options
context:
space:
mode:
authorPranith Kumar K <pkarampu@redhat.com>2013-12-15 08:05:04 +0530
committerPranith Kumar Karampuri <pkarampu@redhat.com>2014-10-15 01:22:02 -0700
commit7e8eefca2caaaa61e1b31b747384f660c595d9c9 (patch)
treea6e862f2caad4097a41dd8b260a2333e90db3b4a /heal/src/Makefile.am
parent7808d4b7892ccd80bcabb1253ee359a64c51c612 (diff)
heal: glfs-heal implementation
Thanks a lot to Niels for helping me to get build stuff right. Change-Id: I634f24d90cd856ceab3cc0c6e9a91003f443403e BUG: 1147462 Signed-off-by: Pranith Kumar K <pkarampu@redhat.com> Reviewed-on: http://review.gluster.org/6529 Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com> Tested-by: Gluster Build System <jenkins@build.gluster.com>
Diffstat (limited to 'heal/src/Makefile.am')
-rw-r--r--heal/src/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/heal/src/Makefile.am b/heal/src/Makefile.am
new file mode 100644
index 00000000000..65093df35cc
--- /dev/null
+++ b/heal/src/Makefile.am
@@ -0,0 +1,35 @@
+sbin_PROGRAMS = glfsheal
+
+glfsheal_SOURCES = glfs-heal.c
+
+glfsheal_LDADD = $(top_builddir)/libglusterfs/src/libglusterfs.la $(GF_LDADD)\
+ $(RLLIBS) $(top_builddir)/rpc/xdr/src/libgfxdr.la \
+ $(top_builddir)/rpc/rpc-lib/src/libgfrpc.la \
+ $(top_builddir)/api/src/libgfapi.la \
+ $(top_builddir)/xlators/cluster/afr/src/afr.la \
+ $(GF_GLUSTERFS_LIBS) $(XML_LIBS)
+
+glfsheal_LDFLAGS = $(GF_LDFLAGS)
+
+AM_CPPFLAGS = $(GF_CPPFLAGS) \
+ -I$(top_srcdir)/xlators/lib/src\
+ -I$(top_srcdir)/xlators/cluster/afr/src\
+ -I$(top_srcdir)/libglusterfs/src -I$(top_srcdir)/rpc/rpc-lib/src\
+ -I$(top_srcdir)/rpc/xdr/src\
+ -I$(top_srcdir)/api/src\
+ -I$(top_srcdir)/contrib/argp-standalone\
+ -DDATADIR=\"$(localstatedir)\" \
+ -DCONFDIR=\"$(sysconfdir)/glusterfs\" \
+ -DGSYNCD_PREFIX=\"$(libexecdir)/glusterfs\"\
+ -DSYNCDAEMON_COMPILE=$(SYNCDAEMON_COMPILE) -DSBIN_DIR=\"$(sbindir)\"\
+ $(XML_CPPFLAGS)
+
+AM_CFLAGS = -Wall $(GF_GLUSTERFS_CFLAGS)
+
+CLEANFILES =
+
+$(top_builddir)/libglusterfs/src/libglusterfs.la:
+ $(MAKE) -C $(top_builddir)/libglusterfs/src/ all
+
+$(top_builddir)/xlators/cluster/afr/src/afr.la:
+ $(MAKE) -C $(top_builddir)/xlators/cluster/afr/src/ all