summaryrefslogtreecommitdiffstats
path: root/glusterfsd/src/Makefile.am
diff options
context:
space:
mode:
authorAnand Avati <avati@gluster.com>2010-07-21 03:53:53 +0000
committerAnand V. Avati <avati@dev.gluster.com>2010-07-21 02:44:06 -0700
commit74195df7a5bdc6ae9489d63a3b8157cbb2ddd8e2 (patch)
tree18dd40688172828a90c729c58ee26a894338f467 /glusterfsd/src/Makefile.am
parentfeefd93f84c7a91365718e30e4e52d765e128f75 (diff)
mount/fuse: disable fuse support from volfile
glusterfsd: implement GETSPEC functionality to fetch volfiles from server Signed-off-by: Anand V. Avati <avati@blackhole.gluster.com> Signed-off-by: Anand V. Avati <avati@dev.gluster.com> BUG: 971 (dynamic volume management) URL: http://bugs.gluster.com/cgi-bin/bugzilla3/show_bug.cgi?id=971
Diffstat (limited to 'glusterfsd/src/Makefile.am')
-rw-r--r--glusterfsd/src/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/glusterfsd/src/Makefile.am b/glusterfsd/src/Makefile.am
index f185f982c8f..af4ce65fab4 100644
--- a/glusterfsd/src/Makefile.am
+++ b/glusterfsd/src/Makefile.am
@@ -4,13 +4,17 @@ glusterfsd_SOURCES = glusterfsd.c fetch-spec.c
if GF_DARWIN_HOST_OS
glusterfsd_SOURCES += $(CONTRIBDIR)/apple/daemon.c
endif
-glusterfsd_LDADD = $(top_builddir)/libglusterfs/src/libglusterfs.la $(GF_LDADD)
+glusterfsd_LDADD = $(top_builddir)/libglusterfs/src/libglusterfs.la \
+ $(top_builddir)/rpc/rpc-lib/src/libgfrpc.la \
+ $(top_builddir)/rpc/xdr/src/libgfxdr.la \
+ $(GF_LDADD)
glusterfsd_LDFLAGS = $(GF_LDFLAGS) $(GF_GLUSTERFS_LDFLAGS)
noinst_HEADERS = glusterfsd.h glusterfsd-common.h glusterfsd-mem-types.h
AM_CFLAGS = -fPIC -Wall -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D$(GF_HOST_OS)\
-I$(top_srcdir)/libglusterfs/src -DDATADIR=\"$(localstatedir)\" \
- -DCONFDIR=\"$(sysconfdir)/glusterfs\" $(GF_GLUSTERFS_CFLAGS)
+ -DCONFDIR=\"$(sysconfdir)/glusterfs\" $(GF_GLUSTERFS_CFLAGS) \
+ -I$(top_srcdir)/rpc/rpc-lib/src -I$(top_srcdir)/rpc/xdr/src
if GF_DARWIN_HOST_OS
AM_CFLAGS += -I$(CONTRIBDIR)/apple
endif