summaryrefslogtreecommitdiffstats
path: root/glusterfsd/src/Makefile.am
diff options
context:
space:
mode:
authorAravinda VK <avishwan@redhat.com>2018-08-17 09:38:39 +0530
committerAmar Tumballi <amarts@redhat.com>2018-09-05 06:44:59 +0000
commit560bd8671f2f9ae17530ad1d23a209dc95d41f82 (patch)
tree61b355b7eba5f8b8decfbdd2f2c64ac574fc30dc /glusterfsd/src/Makefile.am
parent0590678d05473d40c8107be8cf5a66879f9d196f (diff)
New flag to glusterfsd binary to print libexec dir
New CLI option for `glusterfsd` binary to get the path of libexec directory. This helps glusterd2 to detect the installed path of `gsyncd` and other binaries. Usage: `glusterfsd --print-libexecdir` Updates: bz#1193929 Change-Id: I8c1a74afd9acec7ee7bd3deabed9d9f20fe3fb5f Signed-off-by: Aravinda VK <avishwan@redhat.com>
Diffstat (limited to 'glusterfsd/src/Makefile.am')
-rw-r--r--glusterfsd/src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/glusterfsd/src/Makefile.am b/glusterfsd/src/Makefile.am
index 141a7108ae7..7b8d1dbf1fb 100644
--- a/glusterfsd/src/Makefile.am
+++ b/glusterfsd/src/Makefile.am
@@ -21,6 +21,7 @@ AM_CPPFLAGS = $(GF_CPPFLAGS) \
-I$(top_srcdir)/libglusterfs/src -DDATADIR=\"$(localstatedir)\" \
-DCONFDIR=\"$(sysconfdir)/glusterfs\" $(GF_GLUSTERFS_CFLAGS) \
-DXLATORDIR=\"$(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator\" \
+ -DLIBEXECDIR=\"$(GLUSTERFS_LIBEXECDIR)\"\
-I$(top_srcdir)/rpc/rpc-lib/src \
-I$(top_srcdir)/rpc/xdr/src \
-I$(top_builddir)/rpc/xdr/src \