summaryrefslogtreecommitdiffstats
path: root/extras/Makefile.am
diff options
context:
space:
mode:
authorEmmanuel Dreyfus <manu@netbsd.org>2015-04-16 19:28:21 +0200
committerVijay Bellur <vbellur@redhat.com>2015-04-20 04:29:26 -0700
commit1fbcecb72ef3525823536b640d244d1e5127a37f (patch)
tree9f028db0ff61ce4c262d0cc26992eeddbc5c5680 /extras/Makefile.am
parentf45779067dbba3077b9c64c930fd4ddd1c51243e (diff)
Fix case mistake for MKDIR_P in Makefiles
Some makefiles used $(mkdir_p) instead of the corectly defined $(MKDIR_P). The former is substituted as an empty string, leading to possible failures depending of the user shell tolerance. NetBSD's /bin/sh seems to choke more easily than Linux's /bin/bash, but if the later does not fail, it does not created the intended directories anyway. BUG: 1129939 Change-Id: I8caed4000f3c91cb3a685453848fb854793945ed Signed-off-by: Emmanuel Dreyfus <manu@netbsd.org> Reviewed-on: http://review.gluster.org/10276 Tested-by: NetBSD Build System Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Niels de Vos <ndevos@redhat.com>
Diffstat (limited to 'extras/Makefile.am')
-rw-r--r--extras/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/extras/Makefile.am b/extras/Makefile.am
index 1b66708fd90..888c12ec38a 100644
--- a/extras/Makefile.am
+++ b/extras/Makefile.am
@@ -25,10 +25,10 @@ EXTRA_DIST = $(conf_DATA) specgen.scm glusterfs-mode.el glusterfs.vim \
install-data-local:
if [ -n "$(tmpfilesdir)" ]; then \
- $(mkdir_p) $(DESTDIR)$(tmpfilesdir); \
+ $(MKDIR_P) $(DESTDIR)$(tmpfilesdir); \
$(INSTALL_DATA) run-gluster.tmpfiles \
$(DESTDIR)$(tmpfilesdir)/gluster.conf; \
fi
- $(mkdir_p) $(DESTDIR)$(GLUSTERD_WORKDIR)/groups
+ $(MKDIR_P) $(DESTDIR)$(GLUSTERD_WORKDIR)/groups
$(INSTALL_DATA) $(top_srcdir)/extras/group-virt.example \
$(DESTDIR)$(GLUSTERD_WORKDIR)/groups/virt