summaryrefslogtreecommitdiffstats
path: root/extras/Makefile.am
diff options
context:
space:
mode:
authorAshish Pandey <aspandey@redhat.com>2019-01-30 14:24:14 +0530
committerShyamsundar Ranganathan <srangana@redhat.com>2019-03-13 01:48:26 +0000
commit3bcf210a5a9b922ea78b31ef0de8eaf97ff4dcb4 (patch)
tree85c2d03d35b61254603001eab4cc495004179f1b /extras/Makefile.am
parentbda2feeaf2917996c59c0c2188bfa1a17d91895f (diff)
rpm: add thin-arbiter packagev6.0rc1
Discussion on thin arbiter volume - https://github.com/gluster/glusterfs/issues/352#issuecomment-350981148 Main idea of having this rpm package is to deploy thin-arbiter without glusterd and other commands on a node, and all we need on that tie-breaker node is to run a single glusterfs command. Also note that, no other glusterfs installation needs thin-arbiter.so. Make sure RPM contains sample vol file, which can work by default, and a script to configure that volfile, along with translator image. Change-Id: Ibace758373d8a991b6a19b2ecc60c93b2f8fc489 updates: bz#1672818 Signed-off-by: Amar Tumballi <amarts@redhat.com> Signed-off-by: Ashish Pandey <aspandey@redhat.com> (cherry picked from commit ca9bef7f1538beb570fcb190ff94f86f0b8ba38a)
Diffstat (limited to 'extras/Makefile.am')
-rw-r--r--extras/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/extras/Makefile.am b/extras/Makefile.am
index de062f37ecb..ff5ca9bdb83 100644
--- a/extras/Makefile.am
+++ b/extras/Makefile.am
@@ -22,12 +22,13 @@ conf_DATA = glusterfs-logrotate gluster-rsyslog-7.2.conf gluster-rsyslog-5.8.con
endif
voldir = $(sysconfdir)/glusterfs
+vol_DATA = thin-arbiter/thin-arbiter.vol
if WITH_SERVER
-vol_DATA = glusterd.vol
+vol_DATA += glusterd.vol
endif
scriptsdir = $(datadir)/glusterfs/scripts
-scripts_SCRIPTS =
+scripts_SCRIPTS = thin-arbiter/setup-thin-arbiter.sh
if WITH_SERVER
scripts_SCRIPTS += post-upgrade-script-for-quota.sh \
pre-upgrade-script-for-quota.sh stop-all-gluster-processes.sh
@@ -47,7 +48,8 @@ EXTRA_DIST = glusterfs-logrotate gluster-rsyslog-7.2.conf gluster-rsyslog-5.8.co
pre-upgrade-script-for-quota.sh command-completion/gluster.bash \
command-completion/Makefile command-completion/README \
stop-all-gluster-processes.sh clang-checker.sh mount-shared-storage.sh \
- control-cpu-load.sh control-mem.sh group-distributed-virt
+ control-cpu-load.sh control-mem.sh group-distributed-virt \
+ thin-arbiter/thin-arbiter.vol thin-arbiter/setup-thin-arbiter.sh
if WITH_SERVER
install-data-local: