summaryrefslogtreecommitdiffstats
path: root/extras/Makefile.am
diff options
context:
space:
mode:
authorKrutika Dhananjay <kdhananj@redhat.com>2013-09-17 17:01:07 +0530
committerVijay Bellur <vbellur@redhat.com>2014-04-17 11:38:20 -0700
commite55f3fe25a4fd2cc9021fad97faedc5e94aa4e7c (patch)
tree49b54247b4a907378814c033d8ffe88809f2d0af /extras/Makefile.am
parentc7d59dc00860ac6c355845bf79ba787d9e92e036 (diff)
Add upgrade scripts for quota
Change-Id: I289662300d32f75e2fc6e789037c3224054a38a5 BUG: 969461 Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com> Reviewed-on: http://review.gluster.org/7418 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Diffstat (limited to 'extras/Makefile.am')
-rw-r--r--extras/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/extras/Makefile.am b/extras/Makefile.am
index faa91cddf45..525fa97383c 100644
--- a/extras/Makefile.am
+++ b/extras/Makefile.am
@@ -9,11 +9,14 @@ conf_DATA = glusterfs-logrotate gluster-rsyslog-7.2.conf gluster-rsyslog-5.8.con
voldir = $(sysconfdir)/glusterfs
vol_DATA = glusterd.vol
+scriptsdir = $(datadir)/glusterfs/scripts
+scripts_DATA = post-upgrade-script-for-quota.sh pre-upgrade-script-for-quota.sh
EXTRA_DIST = $(conf_DATA) specgen.scm MacOSX/Portfile glusterfs-mode.el \
glusterfs.vim migrate-unify-to-distribute.sh backend-xattr-sanitize.sh \
backend-cleanup.sh disk_usage_sync.sh clear_xattrs.sh \
- glusterd-sysconfig glusterd.vol
+ glusterd-sysconfig glusterd.vol post-upgrade-script-for-quota.sh \
+ pre-upgrade-script-for-quota.sh
install-data-local:
$(mkdir_p) $(DESTDIR)$(localstatedir)/lib/glusterd/groups