summaryrefslogtreecommitdiffstats
path: root/extras/Makefile.am
diff options
context:
space:
mode:
authorEmmanuel Dreyfus <manu@netbsd.org>2015-04-19 03:02:50 +0200
committerVijay Bellur <vbellur@redhat.com>2015-04-22 22:31:42 -0700
commit8611fe7b30f86ddde5d5acfde45a6ec424186e02 (patch)
tree5fc2dcf84abccaa59d233f278c827942ead3d140 /extras/Makefile.am
parent6f0e3981c29beca7d83695ad8f5ab521b129771b (diff)
Fix case mistake for MKDIR_P in Makefiles
Some makefiles used $(mkdir_p) instead of the corectly defined $(MKDIR_P). The former is substituted as an empty string, leading to possible failures depending of the user shell tolerance. NetBSD's /bin/sh seems to choke more easily than Linux's /bin/bash, but if the later does not fail, it does not created the intended directories anyway. Resubmit after rebase in hope that regression test will have less spurious failures. Backport of: I8caed4000f3c91cb3a685453848fb854793945ed BUG: 1212676 Change-Id: I393ffda8aa24bffce86f7b1f19b999ffa30c3562 Signed-off-by: Emmanuel Dreyfus <manu@netbsd.org> Reviewed-on: http://review.gluster.org/10279 Tested-by: NetBSD Build System Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Diffstat (limited to 'extras/Makefile.am')
-rw-r--r--extras/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/extras/Makefile.am b/extras/Makefile.am
index 1b66708fd90..888c12ec38a 100644
--- a/extras/Makefile.am
+++ b/extras/Makefile.am
@@ -25,10 +25,10 @@ EXTRA_DIST = $(conf_DATA) specgen.scm glusterfs-mode.el glusterfs.vim \
install-data-local:
if [ -n "$(tmpfilesdir)" ]; then \
- $(mkdir_p) $(DESTDIR)$(tmpfilesdir); \
+ $(MKDIR_P) $(DESTDIR)$(tmpfilesdir); \
$(INSTALL_DATA) run-gluster.tmpfiles \
$(DESTDIR)$(tmpfilesdir)/gluster.conf; \
fi
- $(mkdir_p) $(DESTDIR)$(GLUSTERD_WORKDIR)/groups
+ $(MKDIR_P) $(DESTDIR)$(GLUSTERD_WORKDIR)/groups
$(INSTALL_DATA) $(top_srcdir)/extras/group-virt.example \
$(DESTDIR)$(GLUSTERD_WORKDIR)/groups/virt