summaryrefslogtreecommitdiffstats
path: root/extras/Makefile.am
diff options
context:
space:
mode:
authorHarshavardhana <harsha@harshavardhana.net>2014-06-29 18:56:44 -0700
committerHarshavardhana <harsha@harshavardhana.net>2014-08-07 01:17:29 -0700
commit2ec6ea43f2ddc6c00a030be6d04c00f0924277b7 (patch)
treeb2d98cd8c4760c1af44c8b6a70661fe5566ce6da /extras/Makefile.am
parentf29da9bcc812e3d0711005ce86051d70c277a165 (diff)
build: make GLUSTERD_WORKDIR rely on localstatedir
- Break-way from '/var/lib/glusterd' hard-coded previously, instead rely on 'configure' value from 'localstatedir' - Provide 's/lib/db' as default working directory for gluster management daemon for BSD and Darwin based installations - loff_t is really off_t on Darwin - fix-off the warnings generated by clang on FreeBSD/Darwin - Now 'tests/*' use GLUSTERD_WORKDIR a common variable for all platforms. - Define proper environment for running tests, define correct PATH and LD_LIBRARY_PATH when running tests, so that the desired version of glusterfs is used, regardless where it is installed. (Thanks to manu@netbsd.org for this additional work) Change-Id: I2339a0d9275de5939ccad3e52b535598064a35e7 BUG: 1111774 Signed-off-by: Harshavardhana <harsha@harshavardhana.net> Signed-off-by: Emmanuel Dreyfus <manu@netbsd.org> Reviewed-on: http://review.gluster.org/8246 Tested-by: Gluster Build System <jenkins@build.gluster.com>
Diffstat (limited to 'extras/Makefile.am')
-rw-r--r--extras/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/extras/Makefile.am b/extras/Makefile.am
index 9395c9c1b65..74b6d17c16b 100644
--- a/extras/Makefile.am
+++ b/extras/Makefile.am
@@ -21,6 +21,6 @@ EXTRA_DIST = $(conf_DATA) specgen.scm MacOSX/Portfile glusterfs-mode.el \
command-completion/Makefile command-completion/README
install-data-local:
- $(mkdir_p) $(DESTDIR)$(localstatedir)/lib/glusterd/groups
+ $(mkdir_p) $(DESTDIR)$(GLUSTERD_WORKDIR)/groups
$(INSTALL_DATA) $(top_srcdir)/extras/group-virt.example \
- $(DESTDIR)$(localstatedir)/lib/glusterd/groups/virt
+ $(DESTDIR)$(GLUSTERD_WORKDIR)/groups/virt