summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmmanuel Dreyfus <manu@netbsd.org>2015-05-09 21:05:02 +0200
committerVijay Bellur <vbellur@redhat.com>2015-05-09 23:41:33 -0700
commitddc263e2998a89030a92c9e5ed7d58db81e12b96 (patch)
treea3ea1067c5c4300f180f2c8d096877a81ed6af65 /configure.ac
parent66f46ab1d119c9d3dda80b163801723761c7af9b (diff)
glupy: remove debug test in libpython runtime search path detection
A configure test was recently added to add libpython runtime search path to glupy.so xlator. The vesion committed was a debug test, it searched pythonxx and not python to check for failure. Fix by removing the xx debug test in python's name. BUG: 1129939 Change-Id: I7b691be17fc2a2c812f68710869b1a9a85ced84c Signed-off-by: Emmanuel Dreyfus <manu@netbsd.org> Reviewed-on: http://review.gluster.org/10732 Reviewed-by: Niels de Vos <ndevos@redhat.com> Tested-by: NetBSD Build System Tested-by: Gluster Build System <jenkins@build.gluster.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 29e0e269b0c..1a09854224b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1131,7 +1131,7 @@ saved_LDFLAGS=$LDFLAGS
# Use pkg-config to get runtime search patch missing from ${PYTHON}-config
# Just do "true" on failure so that configure does not bail out
-PKG_CHECK_MODULES([PYTHON], "pythonxx-$PYTHON_VERSION",,true)
+PKG_CHECK_MODULES([PYTHON], "python-$PYTHON_VERSION",,true)
CFLAGS="`${PYTHON}-config --cflags`"
CPPFLAGS=$CFLAGS
LDFLAGS="${PYTHON_LIBS} -L`${PYTHON}-config --prefix`/lib -L`${PYTHON}-config --prefix`/$libdir `${PYTHON}-config --ldflags`"