summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmmanuel Dreyfus <manu@netbsd.org>2020-06-30 16:42:36 +0200
committerEmmanuel Dreyfus <manu@netbsd.org>2020-06-30 16:43:25 +0200
commitb29d5236ec6a41842752043bbe602a1510ac12f3 (patch)
tree995855cc0e7713af8435be473e596df700e08d9b /configure.ac
parent384431030a7f2c4d303cabe1406a87be773ba0c4 (diff)
NetBSD build fixes
- Make sure -largp is used at link time - PTHREAD_MUTEX_ADAPTIVE_NP is not available, use PTHREAD_MUTEX_DEFAULT instead - Avoid non POSIX [[ ]] in scripts - Do not check of lock.spinlock is NULL since it is not a pointer (it is not a pointer on Linux either) Change-Id: I5e04a7c552d24f8a473c2b837828d1bddfa7e128 Fixes: #1347 Type: Bug Signed-off-by: Emmanuel Dreyfus <manu@netbsd.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c2dc20260bd..b3966e0a783 100644
--- a/configure.ac
+++ b/configure.ac
@@ -968,6 +968,9 @@ case $host_os in
CFLAGS="${CFLAGS} -isystem /usr/local/include"
ARGP_LDADD=-largp
;;
+ *netbsd*)
+ ARGP_LDADD=-largp
+ ;;
esac
dnl argp-standalone does not provide a pkg-config file
AC_CHECK_HEADER([argp.h], AC_DEFINE(HAVE_ARGP, 1, [have argp]))