summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNiels de Vos <ndevos@redhat.com>2014-12-01 09:21:32 +0100
committerRaghavendra Bhat <raghavendra@redhat.com>2014-12-10 06:00:22 -0800
commit54d2cbc033dadcd017376584b70af5849146ee4f (patch)
tree26db62fa06865b3eb7f1b87920d21b13d6622b2e /configure.ac
parentbfc9f1f8d94db1d666e549f3e382be75839c1bf7 (diff)
build: only install geo-rep scripts when enabled
When geo-replication is not enabled, the related scripts should not get installed. EPEL-5 does not support geo-replication, and the installed but unpackaged scripts cause rebuilding for .el5 to fail. Cherry picked from commit fcdac758ad7b3dda9843f92597a15e4a30a3b746: > BUG: 1169005 > Change-Id: I1b6a352b73bd1ed1c5b330f54e26e81aed9a5a4e > Reported-by: Lalatendu Mohanty <lmohanty@redhat.com> > Signed-off-by: Niels de Vos <ndevos@redhat.com> > Reviewed-on: http://review.gluster.org/9221 > Reviewed-by: Humble Devassy Chirammal <humble.devassy@gmail.com> > Tested-by: Gluster Build System <jenkins@build.gluster.com> Change-Id: I1b6a352b73bd1ed1c5b330f54e26e81aed9a5a4e BUG: 1169004 Signed-off-by: Niels de Vos <ndevos@redhat.com> Reviewed-on: http://review.gluster.org/9248 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Humble Devassy Chirammal <humble.devassy@gmail.com> Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com> Tested-by: Raghavendra Bhat <raghavendra@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c4896b56fc9..8ad8eb6af8d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -588,7 +588,13 @@ AC_SUBST(SYNCDAEMON_COMPILE)
AC_SUBST(SYNCDAEMON_SUBDIR)
# end SYNCDAEMON section
-# CDC xlator - check if libz is present if so enable HAVE_LIB_Z
+# only install scripts from extras/geo-rep when enabled
+if test "x$enable_georeplication" != "xno"; then
+ GEOREP_EXTRAS_SUBDIR=geo-rep
+fi
+AC_SUBST(GEOREP_EXTRAS_SUBDIR)
+
+# CDC xlator - check if libz is present if so enable HAVE_LIB_Z
BUILD_CDC=yes
PKG_CHECK_MODULES([ZLIB], [zlib >= 1.2.0],,
[AC_CHECK_LIB([z], [deflate], [ZLIB_LIBS="-lz"],