summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmmanuel Dreyfus <manu@netbsd.org>2014-11-28 17:19:14 +0100
committerRaghavendra Bhat <raghavendra@redhat.com>2014-12-12 22:13:00 -0800
commit52df13da57a6aac1b5c6b37d26d39a4d2cd4ec42 (patch)
treea81e47e26e75ad2cba5a2f982f9483cc0b03f57c /configure.ac
parentceaa61bef43749f9ae8290a1fbe630aab9ed5943 (diff)
glupy: build fix if python and glusterfs prefix differ
If python is installed in ${pythonprefix} and glusterfs in ${glusterfsprefix}, we have the following values: ${PYTHON}-config --prefix => ${pythonprefix} $libdir => ${glusterfsprefix}/lib Using LDFLAGS="-L`${PYTHON}-config --prefix`/$libdir" we lookf for python libraries in ${pythonprefix}/${glusterfsprefix}/lib while we should be looking for ${pythonprefix}/lib Replacing $libdir by lib breaks bug 1159248, so let us look in both ${pythonprefix}/lib and ${pythonprefix}/$libdir Backport of: I2fef1b795235d1543a0e5ac619c6c2d59127fb66 BUG: 1138897 Change-Id: I29b9f121e1cdc546ca8551ff48cc99f1c71a0ea6 Signed-off-by: Emmanuel Dreyfus <manu@netbsd.org> Reviewed-on: http://review.gluster.org/9214 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Vijay Bellur <vbellur@redhat.com> Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com> Tested-by: Raghavendra Bhat <raghavendra@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8ad8eb6af8d..f18238355bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -977,7 +977,8 @@ saved_LDFLAGS=$LDFLAGS
CFLAGS="`${PYTHON}-config --cflags`"
CPPFLAGS=$CFLAGS
-LDFLAGS="-L`${PYTHON}-config --prefix`/lib `${PYTHON}-config --ldflags`"
+LDFLAGS="-L`${PYTHON}-config --prefix`/lib -L`${PYTHON}-config --prefix`/$libdir `${PYTHON}-config --ldflags`"
+
AC_CHECK_HEADERS([python$PYTHON_VERSION/Python.h],[have_Python_h=yes],[])
AC_ARG_ENABLE([glupy],