summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNiels de Vos <ndevos@redhat.com>2019-02-22 15:17:48 +0100
committerNiels de Vos <ndevos@redhat.com>2019-02-25 11:16:43 +0000
commitfce763a6fcd9331356e7d32c1aa8daf9e991aa56 (patch)
treec3deefd887520fd62eb48419107c3af3ad1e4d1a /configure.ac
parent5801a0e30e317bb752a121187332ba9f307cbb62 (diff)
build: include gluster/__init__.* files for python packaging
The gluster/__init__.py file was originaly part of the glupy installation. This file is required to have the python-gluster package function correctly, it is expected to provide the 'gluster' namespace for other python packages (like from the libgfapi-python project). Because glupy does not exist anymore, this file is now added to in a new extras/python directory. Backport of commit b235a56394c09bb1d7308a620053dbe098d15967: > Change-Id: I14fe959778ee3344d7d54ba342c7928a4d8080a2 > Fixes: c3fcff9ccbfcec1be242fd5cf210c9995586b078 > Fixes: 8293d21280fd6ddfc9bb54068cf87794fc6be207 > Updates: bz#1642810 > Signed-off-by: Niels de Vos <ndevos@redhat.com> Change-Id: I04e1e0dc4022b53c02053d5452f305b78e56c389 Updates: bz#1680585 Signed-off-by: Niels de Vos <ndevos@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8752ca043bf..7ae98ca104b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -226,6 +226,7 @@ AC_CONFIG_FILES([Makefile
extras/hook-scripts/reset/Makefile
extras/hook-scripts/reset/post/Makefile
extras/hook-scripts/reset/pre/Makefile
+ extras/python/Makefile
extras/snap_scheduler/Makefile
events/Makefile
events/src/Makefile
@@ -630,6 +631,7 @@ AM_PATH_PYTHON([2.6],,[:])
if test -n "${PYTHON}"; then
have_python=yes
fi
+AM_CONDITIONAL(HAVE_PYTHON, test "x$have_python" = "xyes")
dnl Use pkg-config to get runtime search path missing from ${PYTHON}-config
dnl Just do "true" on failure so that configure does not bail out