summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNiels de Vos <ndevos@redhat.com>2018-07-30 17:15:35 +0200
committerAmar Tumballi <amarts@redhat.com>2018-08-16 06:55:21 +0000
commitfa2f092709a6a2d91213cb3410fc5b5109d84646 (patch)
tree1238bc8947fee3bb97e1857bc1127efe5ceabd69 /configure.ac
parent90b102fa0361523a706a25c85b56ee6f536f6277 (diff)
build: use standard PKG_CHECK_MODULES for libxml2 availability
In case the development parts of libxml2 are not installed, it was required to re-run ./autogen.sh to cleanup the cached values for the check. This is not nice towards users. By using the standard PKG_CHECK_MODULES for libxml-2.0 the results of the check are not cached and will be probed again when running ./configure. Change-Id: I3c4586e5555a521be5d4fb61bdb873ae0317311a Fixes: bz#1599219 Reported-by: Sachidananda Urs <surs@redhat.com> Signed-off-by: Niels de Vos <ndevos@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index efd98c53012..54b52a35f8c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -963,8 +963,7 @@ AC_ARG_ENABLE([xml-output],
[Disable the xml output]))
BUILD_XML_OUTPUT="yes"
if test "x$enable_xml_output" != "xno"; then
- #check if libxml is present if so enable HAVE_LIB_XML
- m4_ifdef([AM_PATH_XML2],[AM_PATH_XML2([2.6.19])], [no_xml=yes])
+ PKG_CHECK_MODULES([XML], [libxml-2.0], [], [no_xml="yes"])
if test "x${no_xml}" = "x"; then
AC_DEFINE([HAVE_LIB_XML], [1], [Define to 1 if using libxml2.])
else