summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAmar Tumballi <amarts@redhat.com>2018-10-03 17:13:09 +0530
committerAmar Tumballi <amarts@redhat.com>2018-11-08 02:46:48 +0000
commitc3fcff9ccbfcec1be242fd5cf210c9995586b078 (patch)
tree642aabe219e7d5b7b584e97c03976b64d0f86ec5 /configure.ac
parente78682bb7c2e40b7f818efdcd56aca459b9dbb03 (diff)
glupy: remove from the build
Based on the proposal to remove few features as they are not actively maintained [1], removing 'glupy' translator from the build. [1] https://lists.gluster.org/pipermail/gluster-users/2018-July/034400.html This patch aims at clearing the translator from build and tests. A followup is needed to remove the code from repository. Updates: bz#1642810 Change-Id: I41d0c1956330c3bbca62c540ccf9ab01bbf3a092 Signed-off-by: Amar Tumballi <amarts@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac45
1 files changed, 1 insertions, 44 deletions
diff --git a/configure.ac b/configure.ac
index fbdc2f2064b..3f693855840 100644
--- a/configure.ac
+++ b/configure.ac
@@ -125,12 +125,6 @@ AC_CONFIG_FILES([Makefile
xlators/features/changelog/src/Makefile
xlators/features/changelog/lib/Makefile
xlators/features/changelog/lib/src/Makefile
- xlators/features/glupy/Makefile
- xlators/features/glupy/examples/Makefile
- xlators/features/glupy/src/Makefile
- xlators/features/glupy/src/setup.py
- xlators/features/glupy/src/__init__.py
- xlators/features/glupy/src/glupy/Makefile
xlators/features/locks/Makefile
xlators/features/locks/src/Makefile
xlators/features/quota/Makefile
@@ -1393,42 +1387,6 @@ if test -n "$LIBAIO"; then
BUILD_LIBAIO=yes
fi
-dnl glupy section
-BUILD_GLUPY=no
-
-AC_ARG_ENABLE([glupy], AS_HELP_STRING([--disable-glupy], [disable building glupy]))
-
-if test "x$enable_glupy" != "xno"; then
- if test "x${have_python}" = "xyes" -a -n "${PYTHON_CFLAGS}"; then
- case $host_os in
- darwin*)
- BUILD_GLUPY=no
- ;;
- *)
- BUILD_GLUPY=yes
- ;;
- esac
- else
- AC_MSG_WARN([
- ---------------------------------------------------------------------------------
- cannot build glupy. python ${PYTHON_VERSION} and python-devel/python-dev package are required.
- ---------------------------------------------------------------------------------])
- fi
-
- if test "x$BUILD_GLUPY" = "xyes"; then
- GLUPY_SUBDIR=glupy
- GLUPY_SUBDIR_MAKEFILE=xlators/features/glupy/Makefile
- GLUPY_SUBDIR_SRC_MAKEFILE=xlators/features/glupy/src/Makefile
-
- echo "building glupy with -isystem ${PYTHON_CFLAGS} ${PYTHON_LIBS}"
-
- AC_SUBST(GLUPY_SUBDIR)
- AC_SUBST(GLUPY_SUBDIR_MAKEFILE)
- AC_SUBST(GLUPY_SUBDIR_SRC_MAKEFILE)
- fi
-fi
-dnl end glupy section
-
dnl gnfs section
BUILD_GNFS="no"
AC_ARG_ENABLE([gnfs],
@@ -1592,7 +1550,7 @@ case $host_os in
esac
dnl GF_XLATOR_DEFAULT_LDFLAGS is for most xlators that expose a common set of symbols
GF_XLATOR_DEFAULT_LDFLAGS='-avoid-version -export-symbols $(top_srcdir)/xlators/xlator.sym $(UUID_LIBS) $(GF_NO_UNDEFINED)'
-dnl GF_XLATOR_LDFLAGS is for xlators that expose extra symbols, e.g. dht and glupy
+dnl GF_XLATOR_LDFLAGS is for xlators that expose extra symbols, e.g. dht
GF_XLATOR_LDFLAGS='-avoid-version $(UUID_LIBS) $(GF_NO_UNDEFINED)'
AC_SUBST(GF_HOST_OS)
@@ -1679,7 +1637,6 @@ echo "Linux-AIO : $BUILD_LIBAIO"
echo "Enable Debug : $BUILD_DEBUG"
echo "Enable ASAN : $BUILD_ASAN"
echo "Block Device xlator : $BUILD_BD_XLATOR"
-echo "glupy : $BUILD_GLUPY"
echo "Use syslog : $USE_SYSLOG"
echo "XML output : $BUILD_XML_OUTPUT"
echo "Encryption xlator : $BUILD_CRYPT_XLATOR"