summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmmanuel Dreyfus <manu@netbsd.org>2014-07-28 14:49:16 +0200
committerAnand Avati <avati@redhat.com>2014-07-28 09:58:30 -0700
commite55e1e0ee1352bbbbd847c6e188950cf1fccc8d5 (patch)
tree039143ee682e54d45c9c3da3244fcc8ecd90e5cf /configure.ac
parent8d75177c74eb18a7a6ec37b3550898eeffe87b8e (diff)
Disable Erasure Code xlator if MMX is missing
Erasure Code xlator requires MMX instruction set. Disable building it if MMX is missing. This is a backport of Id9fe87db33e00c5630c1f3633ebd50fc4ebaec4d BUG: 764655 Change-Id: I880109e42838b5b35ce68508eeb0f8f005faf6f1 Signed-off-by: Emmanuel Dreyfus <manu@netbsd.org> Reviewed-on: http://review.gluster.org/8381 Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com> Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Harshavardhana <harsha@harshavardhana.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8d8b971ab6f..16739cc9812 100644
--- a/configure.ac
+++ b/configure.ac
@@ -321,6 +321,9 @@ AC_CHECK_LIB([readline], [rl_do_undo], [RL_UNDO="yes"], [RL_UNDO="no"])
AC_CHECK_LIB([intl], [gettext])
+dnl Erasure Code xlator requires MMX instruction set
+AC_CHECK_HEADERS([xmmintrin.h], [enable_ec_xlator=yes], [enable_ec_xlator=no])
+
AC_CHECK_HEADERS([sys/xattr.h])
AC_CHECK_HEADERS([sys/ioctl.h], AC_DEFINE(HAVE_IOCTL_IN_SYS_IOCTL_H, 1, [have sys/ioctl.h]))
@@ -447,6 +450,14 @@ fi
AC_SUBST(FUSERMOUNT_SUBDIR)
#end FUSERMOUNT section
+# Erasure Code xlator section
+BUILD_EC_XLATOR=no
+if test "x$enable_ec_xlator" = "xyes" ; then
+ EC_XLATOR_SUBDIR=ec
+ BUILD_EC_XLATOR="yes"
+fi
+AC_SUBST(EC_XLATOR_SUBDIR)
+
# QEMU_BLOCK section
AC_ARG_ENABLE([qemu-block],
@@ -1071,4 +1082,5 @@ echo "Use syslog : $USE_SYSLOG"
echo "XML output : $BUILD_XML_OUTPUT"
echo "QEMU Block formats : $BUILD_QEMU_BLOCK"
echo "Encryption xlator : $BUILD_CRYPT_XLATOR"
+echo "Erasure Code xlator : $BUILD_EC_XLATOR"
echo