summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-03-09 23:06:43 +0000
committerAmar Tumballi <amarts@redhat.com>2018-03-24 05:14:05 +0000
commitd978ff0e3a0c365c794f069aa56364454b241f12 (patch)
tree38550ff27e62cdf2d849a1f1d831807f7f9dea8c /configure.ac
parentd121b97f9ad1fdca36f1e79a934e09a9d3066866 (diff)
build: Fix misleading TIRPC result in configure summary
Requesting ipv6-default even if you explicitly disable libtirpc will then implicitly enable libtirpc because that is required. That is fine but the configure summary should not then show TIRPC as disabled when it is not. The result has also been made clearer by stating that TIRPC is "missing" when it has been tried but not found. BUG: 1553938 Change-Id: I945bd6859aaf3defa682b0d05ee34a9827b9c45f Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index d421791826d..9571dac76a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1097,16 +1097,15 @@ AC_SUBST(GF_DISTRIBUTION)
GF_HOST_OS=""
GF_LDFLAGS="-rdynamic"
-DISABLE_LIBTIRPC=no
dnl include tirpc for IPv6 builds
if test "x$with_libtirpc" = "xyes" || test "x$with_ipv6_default" = "xyes" ; then
PKG_CHECK_MODULES([TIRPC], [libtirpc],
- [GF_CFLAGS="$GF_CFLAGS $TIRPC_CFLAGS"; GF_LDFLAGS="$GF_LDFLAGS $TIRPC_LIBS";],
- [DISABLE_LIBTIRPC=yes])
+ [with_libtirpc=yes; GF_CFLAGS="$GF_CFLAGS $TIRPC_CFLAGS"; GF_LDFLAGS="$GF_LDFLAGS $TIRPC_LIBS";],
+ [with_libtirpc=missing])
fi
-if test "x$DISABLE_LIBTIRPC" = "xyes" ; then
- with_libtirpc=no; with_ipv6_default=no
+if test "x$with_libtirpc" = "xmissing" ; then
+ with_ipv6_default=no
AC_CHECK_HEADERS([rpc/rpc.h],[
AC_MSG_WARN([
---------------------------------------------------------------------------------