summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCsaba Henk <csaba@gluster.com>2011-01-27 05:23:35 +0000
committerAnand V. Avati <avati@dev.gluster.com>2011-01-27 03:17:20 -0800
commit85300e25f2d47e33b169d14fa9eb0b7cfe39011b (patch)
tree6a00e8790358f1321855122d90a78e669168c1d1 /configure.ac
parent7d883898c5225df3f7c38e67274b74ff8ac396c0 (diff)
adding syncdaemon
Signed-off-by: Csaba Henk <csaba@gluster.com> Signed-off-by: Anand V. Avati <avati@dev.gluster.com> BUG: 2310 (georeplication) URL: http://bugs.gluster.com/cgi-bin/bugzilla3/show_bug.cgi?id=2310
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 34 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e8d3c07a897..3ce78028f58 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,6 +93,9 @@ AC_CONFIG_FILES([Makefile
xlators/features/quota/src/Makefile
xlators/features/marker/Makefile
xlators/features/marker/src/Makefile
+ xlators/features/marker/utils/Makefile
+ xlators/features/marker/utils/gsyncd
+ xlators/features/marker/utils/syncdaemon/Makefile
xlators/features/read-only/Makefile
xlators/features/read-only/src/Makefile
xlators/features/mac-compat/Makefile
@@ -281,6 +284,36 @@ AC_SUBST(RDMA_SUBDIR)
# end IBVERBS section
+# SYNCDAEMON section
+AC_ARG_ENABLE([georeplication],
+ AC_HELP_STRING([--disable-georeplication],
+ [Do not install georeplication components]))
+
+BUILD_SYNCDAEMON=no
+if test "x$enable_georeplication" != "xno"; then
+ SYNCDAEMON_SUBDIR=utils
+ BUILD_SYNCDAEMON="yes"
+ AM_PATH_PYTHON([2.4])
+ echo -n "checking if python is python 2.x... "
+ if echo $PYTHON_VERSION | grep ^2; then
+ :
+ else
+ echo no
+ AC_MSG_ERROR([only python 2.x is supported])
+ fi
+ echo -n "checking if python has ctypes support... "
+ if "$PYTHON" -c 'import ctypes' 2>/dev/null; then
+ echo yes
+ else
+ echo no
+ AC_MSG_ERROR([python does not have ctypes support])
+ fi
+fi
+
+AC_SUBST(SYNCDAEMON_SUBDIR)
+# end SYNCDAEMON section
+
+
dnl FreeBSD > 5 has execinfo as a Ported library for giving a workaround
dnl solution to GCC backtrace functionality
@@ -430,4 +463,5 @@ echo "epoll IO multiplex : $BUILD_EPOLL"
echo "argp-standalone : $BUILD_ARGP_STANDALONE"
echo "fusermount : $BUILD_FUSERMOUNT"
echo "readline : $BUILD_READLINE"
+echo "georeplication : $BUILD_SYNCDAEMON"
echo