summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKaleb S. KEITHLEY <kkeithle@redhat.com>2017-03-27 16:09:56 -0400
committerKaleb KEITHLEY <kkeithle@redhat.com>2017-04-28 14:08:41 +0000
commit83abcba6b42f94eb5a6495a634d4055362a9d79d (patch)
tree401e7638258acf9ef4c04af00a0bbfc443b570e3 /configure.ac
parentab88f655e6423f51e2f2fac9265ff4d4f5c3e579 (diff)
build: conditionally build legacy gNFS server and associated sub-packaging
Plus some additional logic in glusterd to ensure gnfs (glusterfs) daemons are never started if server/nfs xlator is not installed. As a service, nfs is still initialized. The glusterfs-gnfs RPM may be installed or uninstalled independent of anything else, including on a system where gluster is actively running, so the existence of the xlator is always tested before trying to start gnfs. Change-Id: I56743ad1cb36a84917226d7d26cb9d015d441e66 BUG: 1326219 Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com> Reviewed-on: https://review.gluster.org/16958 Smoke: Gluster Build System <jenkins@build.gluster.org> CentOS-regression: Gluster Build System <jenkins@build.gluster.org> NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 960a43cbe3b..cdac77b9574 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1335,6 +1335,17 @@ if test "x$enable_glupy" = "xyes"; then
fi
dnl end glupy section
+dnl gnfs section
+BUILD_GNFS="no"
+AC_ARG_ENABLE([gnfs],
+ AC_HELP_STRING([--enable-gnfs],
+ [Enable legacy gnfs server xlator.]))
+if test "x$enable_gnfs" = "xyes"; then
+ BUILD_GNFS="yes"
+fi
+AM_CONDITIONAL([BUILD_GNFS], [test x$BUILD_GNFS = xyes])
+dnl end gnfs section
+
dnl Check for userspace-rcu
PKG_CHECK_MODULES([URCU], [liburcu-bp], [],
[AC_CHECK_HEADERS([urcu-bp.h],
@@ -1581,4 +1592,5 @@ echo "Events : $BUILD_EVENTS"
echo "EC dynamic support : $EC_DYNAMIC_SUPPORT"
echo "Use memory pools : $USE_MEMPOOL"
echo "Nanosecond m/atimes : $BUILD_NANOSECOND_TIMESTAMPS"
+echo "Legacy gNFS server : $BUILD_GNFS"
echo