summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin Vigor <kvigor@fb.com>2017-04-28 16:44:29 -0700
committerAmar Tumballi <amarts@redhat.com>2017-10-24 09:28:08 +0000
commit1260ee53b1674234e6f083563bdcd258e46a6faa (patch)
treea1e31987357722438f603622a43151839c83a13e /configure.ac
parent738c38f0efa7b4d4dab0cf23d00589d68e4eb88d (diff)
gluster: IPv6 single stack support
Summary: - This diff changes all locations in the code to prefer inet6 family instead of inet. This will allow change GlusterFS to operate via IPv6 instead of IPv4 for all internal operations while still being able to serve (FUSE or NFS) clients via IPv4. - The changes apply to NFS as well. - This diff ports D1892990, D1897341 & D1896522 to the 3.8 branch. Test Plan: Prove tests! Reviewers: dph, rwareing Signed-off-by: Shreyas Siravara <sshreyas@fb.com> Change-Id: I34fdaaeb33c194782255625e00616faf75d60c33 BUG: 1406898 Reviewed-on-3.8-fb: http://review.gluster.org/16059 Reviewed-by: Shreyas Siravara <sshreyas@fb.com> Tested-by: Shreyas Siravara <sshreyas@fb.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 418ded7fe87..cc1410f9e8d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -312,6 +312,20 @@ else
CFLAGS="${CFLAGS} -g -rdynamic"
fi
+AC_ARG_WITH([ipv6-default], AC_HELP_STRING([--with-ipv6-default], [Set IPv6 as default.]))
+if test "x$with_ipv6_default" = "xyes"; then
+ IPV6_DEFAULT=yes
+else
+ IPV6_DEFAULT=no
+fi
+if test "x$ac_cv_file__etc_redhat_release" = "xyes"; then
+ if rpm -qa centos-release | grep centos; then
+ if rpm -q centos-release | grep "release-6"; then
+ IPV6_DEFAULT=no;
+ fi
+ fi
+fi
+
AC_ARG_ENABLE([privport_tracking],
AC_HELP_STRING([--disable-privport_tracking],
[Disable internal tracking of privileged ports.]))
@@ -1071,6 +1085,14 @@ AC_SUBST(GF_DISTRIBUTION)
GF_HOST_OS=""
GF_LDFLAGS="-rdynamic"
+dnl include tirpc for IPv6 builds
+if test "x$IPV6_DEFAULT" = "xyes"; then
+ AC_CHECK_LIB([tirpc], [xdr_string], , AC_MSG_ERROR([libtirpc is required to build glusterfs with IPv6 default]))
+ TIRPC_CFLAGS="-I/usr/include/tirpc"
+ GF_LDFLAGS="-ltirpc $GF_LDFLAGS"
+ GF_CFLAGS="$GF_CFLAGS $TIRPC_CFLAGS -DIPV6_DEFAULT"
+fi
+
dnl check for gcc -Werror=format-security
saved_CFLAGS=$CFLAGS
CFLAGS="-Wformat -Werror=format-security"