summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKaleb S. KEITHLEY <kkeithle@redhat.com>2014-04-10 14:43:47 -0400
committerAnand Avati <avati@redhat.com>2014-04-13 14:34:37 -0700
commit09d2dcac3a238cfe6bde1a7aed06facfa16caf20 (patch)
treec543095b6605ee7cae5ea982dfdb6482682db0f1 /configure.ac
parentc193996c94901d81a2a623799d83ef96f595d3e2 (diff)
configure: argp-standalone is always built, even when not needed
This patch still configures argp, i.e. creates Makefile in /contrib/argp-standalone, for the `make dist`, but there's no reason to compile it when it's not going to be linked into anything. Change-Id: Id0fcb717b5821d8a4c176e6274339f46b3a4a249 BUG: 1086773 Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com> Reviewed-on: http://review.gluster.org/7440 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Harshavardhana <harsha@harshavardhana.net> Reviewed-by: Niels de Vos <ndevos@redhat.com> Reviewed-by: Anand Avati <avati@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d146b38c661..65e8cb7535f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -656,6 +656,7 @@ if test "x${ac_cv_header_argp_h}" = "xno"; then
BUILD_ARGP_STANDALONE=yes
ARGP_STANDALONE_CPPFLAGS='-I${top_srcdir}/contrib/argp-standalone'
ARGP_STANDALONE_LDADD='${top_builddir}/contrib/argp-standalone/libargp.a'
+ ARGP_STANDALONE_DIR='${top_builddir}/contrib/argp-standalone'
fi
AC_SUBST(ARGP_STANDALONE_CPPFLAGS)