summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarshavardhana <harsha@harshavardhana.net>2014-05-30 01:07:04 -0700
committerAnand Avati <avati@redhat.com>2014-06-04 16:24:32 -0700
commitea58f256463efb07824dbd307af06f2c3960f254 (patch)
tree2de22ec3ce5e2d065ec32b07f89ca9cc679eca45 /configure.ac
parent1f95e55cc633e9b082b4eb37a6a825c0e33ac5c8 (diff)
build: Avoid gcc pragmas when clang is enabled
Change-Id: I86544a9bfd24ef1a69315c0f6c3abcdd9aeb2c69 BUG: 1089172 Signed-off-by: Harshavardhana <harsha@harshavardhana.net> Reviewed-on: http://review.gluster.org/7932 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Anand Avati <avati@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 04b6c72fd12..2c69ccdc1c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -774,7 +774,7 @@ AC_COMPILE_IFELSE(
AC_MSG_RESULT([$CLANG])
if test "x$CLANG" = "xyes"; then
- GF_COMPILER_FLAGS="-Wno-gnu -Wno-unknown-pragmas -Wno-deprecated-declarations -Wno-enum-conversion"
+ GF_COMPILER_FLAGS="-Wno-gnu -Wno-deprecated-declarations -Wno-enum-conversion"
fi