summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmmanuel Dreyfus <manu@netbsd.org>2013-12-19 14:11:45 +0100
committerVijay Bellur <vbellur@redhat.com>2014-01-02 22:01:48 -0800
commitd1f8b7ebc71df415f6b8ff37e9654ecee0d9064c (patch)
treea7376a9dd9f0475a7b763e16c5cbf86c9ae450d4 /configure.ac
parent2ce8918759e9676a54791848fd2ac85f48a05016 (diff)
Use linkat() instead of link() for portability sake
POSIX does not says wether link(2) on symlink should link on symlink itself or on target. Linux use symlink, most other systems use target. Using linkat(2) allows the behavior to be specified, so that the behavior is portable. Also fix configure test for NetBSD linkata(2), which ceased to work. BUG: 764655 Change-Id: Iccd27ac076b7a74e40dcbaa1c4762fd3ad59da5f Signed-off-by: Emmanuel Dreyfus <manu@netbsd.org> Reviewed-on: http://review.gluster.org/6539 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7bfee047ae2..be1ec7ab670 100644
--- a/configure.ac
+++ b/configure.ac
@@ -598,7 +598,7 @@ dnl FreeBSD, NetBSD
AC_CHECK_MEMBERS([struct stat.st_atimespec.tv_nsec])
case $host_os in
*netbsd*)
- CFLAGS+=" -D_INCOMPLETE_XOPEN_C063"
+ CFLAGS="${CFLAGS} -D_INCOMPLETE_XOPEN_C063"
;;
esac
AC_CHECK_FUNC([linkat], [have_linkat=yes])