summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNiels de Vos <ndevos@redhat.com>2015-04-16 17:46:49 +0530
committerNiels de Vos <ndevos@redhat.com>2015-04-24 05:22:47 -0700
commitbfce25666d8a0d198292df4884d7d8d56ec0dc8c (patch)
tree2c7d7fac9457ddbede7c700a715bdef48328bfe3 /configure.ac
parent0d00b9d66009787b90a429ab46b2f00927517dc3 (diff)
build: correct the version in glusterfs-api.pc
The version in glusterfs-api.pc has moved backwards, breaking existing versioned dependencies in QEMU. The following table contains the GlusterFS version and the version for glusterfs-api.pc: .------------------------. | GlusterFS | pkg-config | |-----------+------------| | 3.4.x | 4.3.4.x | | 3.5.x | 6.3.5.x | | 3.6.x | 7.3.6.x | | 3.7.x | 7.3.7.x | | master | 7.x.y.z | '------------------------' BUG: 1211841 Change-Id: I62168a0ab4f0c78e61987371ae75a0d2dd56ced8 URL: http://thread.gmane.org/gmane.comp.emulators.qemu/330176 Reported-by: Andreas Färber <afaerber@suse.de> Signed-off-by: Niels de Vos <ndevos@redhat.com> Reviewed-on: http://review.gluster.org/10311 Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com> Tested-by: Gluster Build System <jenkins@build.gluster.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index e1a207016de..6267437b3f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -897,15 +897,15 @@ AM_CONDITIONAL([GF_INSTALL_VAR_LIB_GLUSTERD], test ! -d ${localstatedir}/lib/glu
dnl pkg-config versioning
dnl
-dnl Once we released gluster-api.pc with version=4. Since then we undid the
-dnl library versioning and replaced it with symbol-versioning. The current
+dnl Once we released gluster-api.pc in 3.5 with version=6. Since then we undid
+dnl the library versioning and replaced it with symbol-versioning. The current
dnl libgfapi.so has version 0, but the symbols have the version from the main
dnl package at the time they were added.
dnl
dnl Because other packages (like samba) use the pkg-config version, we can not
dnl drop it, or decrease the version easily. The simplest solution is to keep
-dnl the version=4 and add sub-digits for the actual package/symbol versions.
-GFAPI_VERSION="4."${PACKAGE_VERSION}
+dnl the version=6 and add sub-digits for the actual package/symbol versions.
+GFAPI_VERSION="6."${PACKAGE_VERSION}
AC_SUBST(GFAPI_VERSION)
AC_OUTPUT