summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCsaba Henk <csaba@gluster.com>2010-05-28 07:00:42 +0000
committerAnand V. Avati <avati@dev.gluster.com>2010-05-31 05:39:22 -0700
commit5e03484d1d24ae93f7cad5fe575edd9ce8e0195b (patch)
tree67ac4565acbd782d20bf6e32f0e2718b86428b6d /configure.ac
parenta841aba0844e69e3a11205f4f0b5176bcc0cb362 (diff)
OS X: make location of launchd service configurable
Signed-off-by: Csaba Henk <csaba@gluster.com> Signed-off-by: Anand V. Avati <avati@dev.gluster.com> BUG: 361 (GlusterFS 3.0 should work on Mac OS/X) URL: http://bugs.gluster.com/cgi-bin/bugzilla3/show_bug.cgi?id=361
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7c1ef206f1e..9c1c32a01b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -135,6 +135,12 @@ AC_ARG_WITH(initdir,
[initdir='/etc/init.d'])
AC_SUBST(initdir)
+AC_ARG_WITH(launchddir,
+ [ --with-launchddir=DIR launchd services in DIR @<:@/Library/LaunchDaemons@:>@],
+ [launchddir=$withval],
+ [launchddir='/Library/LaunchDaemons'])
+AC_SUBST(launchddir)
+
# LEX needs a check
AC_PROG_LEX
if test "x${LEX}" != "xflex" -a "x${FLEX}" != "xlex"; then