summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRaghavendra G <raghavendra@gluster.com>2010-08-31 03:20:29 +0000
committerVijay Bellur <vijay@dev.gluster.com>2010-08-31 04:33:36 -0700
commitcd5d2fc036003eb0c1a7f91755d3f5aa327067b4 (patch)
treef23599de025c4ea7f75ab5222771c8e054fca729 /configure.ac
parente41b82c5704b0a9caba7c511688c9a152c5f2b0f (diff)
rpc-transport/rdma: By default, enable building of rdma only if libibverbs is installed.
Signed-off-by: Raghavendra G <raghavendra@gluster.com> Signed-off-by: Vijay Bellur <vijay@dev.gluster.com> BUG: 513 (Introduce 0 copy rdma) URL: http://bugs.gluster.com/cgi-bin/bugzilla3/show_bug.cgi?id=513
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d274fe6bc5c..b2cad35de74 100644
--- a/configure.ac
+++ b/configure.ac
@@ -275,14 +275,17 @@ if test "x$enable_ibverbs" = "xyes" -a "x$HAVE_LIBIBVERBS" = "xno"; then
exit 1
fi
-
+BUILD_RDMA=no
BUILD_IBVERBS=no
if test "x$enable_ibverbs" != "xno" -a "x$HAVE_LIBIBVERBS" = "xyes"; then
IBVERBS_SUBDIR=ib-verbs
BUILD_IBVERBS=yes
+ RDMA_SUBDIR=rdma
+ BUILD_RDMA=yes
fi
AC_SUBST(IBVERBS_SUBDIR)
+AC_SUBST(RDMA_SUBDIR)
# end IBVERBS section