summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKaleb S. KEITHLEY <kkeithle@redhat.com>2017-01-20 11:11:46 -0500
committerShyamsundarR <srangana@redhat.com>2017-11-06 09:57:36 -0500
commit6662516d8d8cc935378a734c5c790a23bcc00ab0 (patch)
tree1d0f488d0f6a76262473e8e18408a8076e12f8f4 /configure.ac
parentaa2c149e0555a8e3d194a5328f66623477e337b9 (diff)
core: remove experimental xlators and associated tests
experimental xlators removed from 3.13 > Cherry picked from 4231c40973c60999f5ef759db450d25e129ef6ba: > Reviewed-on: https://review.gluster.org/17953 > Reviewed-by: jiffin tony Thottan <jthottan@redhat.com> Signed-off-by: ShyamsundarR <srangana@redhat.com> Change-Id: I34419ce22ca09b7626b8f9382c377a614fd9fed8 BUG: 1510022
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 0 insertions, 32 deletions
diff --git a/configure.ac b/configure.ac
index cc1410f9e8d..14fc0b826bf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -129,8 +129,6 @@ AC_CONFIG_FILES([Makefile
xlators/features/Makefile
xlators/features/arbiter/Makefile
xlators/features/arbiter/src/Makefile
- xlators/experimental/fdl/Makefile
- xlators/experimental/fdl/src/Makefile
xlators/features/changelog/Makefile
xlators/features/changelog/src/Makefile
xlators/features/changelog/lib/Makefile
@@ -196,23 +194,6 @@ AC_CONFIG_FILES([Makefile
xlators/mgmt/Makefile
xlators/mgmt/glusterd/Makefile
xlators/mgmt/glusterd/src/Makefile
- xlators/experimental/Makefile
- xlators/experimental/jbr-client/Makefile
- xlators/experimental/jbr-client/src/Makefile
- xlators/experimental/jbr-server/Makefile
- xlators/experimental/jbr-server/src/Makefile
- xlators/experimental/dht2/Makefile
- xlators/experimental/dht2/dht2-client/Makefile
- xlators/experimental/dht2/dht2-client/src/Makefile
- xlators/experimental/dht2/dht2-server/Makefile
- xlators/experimental/dht2/dht2-server/src/Makefile
- xlators/experimental/posix2/Makefile
- xlators/experimental/posix2/ds/Makefile
- xlators/experimental/posix2/ds/src/Makefile
- xlators/experimental/posix2/mds/Makefile
- xlators/experimental/posix2/mds/src/Makefile
- xlators/experimental/posix2/common/Makefile
- xlators/experimental/posix2/common/src/Makefile
cli/Makefile
cli/src/Makefile
doc/Makefile
@@ -1444,18 +1425,6 @@ AC_SUBST(UNITTEST_LDFLAGS)
AC_SUBST(CFLAGS)
# end enable debug section
-# experimental section
-AC_ARG_ENABLE([experimental],
- AC_HELP_STRING([--disable-experimental],
- [Disable building experimental xlators]))
-
-BUILD_EXPERIMENTAL="yes"
-if test "x$enable_experimental" = "xno"; then
- BUILD_EXPERIMENTAL="no"
-fi
-AM_CONDITIONAL([ENABLE_EXPERIMENTAL], [test x$BUILD_EXPERIMENTAL = xyes])
-#end experimental section
-
# EC dynamic code generation section
EC_DYNAMIC_SUPPORT="none"
@@ -1639,7 +1608,6 @@ echo "POSIX ACLs : $BUILD_POSIX_ACLS"
echo "Data Classification : $BUILD_GFDB"
echo "SELinux features : $USE_SELINUX"
echo "firewalld-config : $BUILD_FIREWALLD"
-echo "Experimental xlators : $BUILD_EXPERIMENTAL"
echo "Events : $BUILD_EVENTS"
echo "EC dynamic support : $EC_DYNAMIC_SUPPORT"
echo "Use memory pools : $USE_MEMPOOL"