summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarshavardhana <harsha@zresearch.com>2009-02-27 05:03:50 -0800
committerAnand V. Avati <avati@amp.gluster.com>2009-03-03 11:43:39 +0530
commitb29a555c0be1c0db47c290d61f8c4dfe1e6fecbf (patch)
treef6b601f2b9b061e25aeafbd44c92578a8e1982e8 /configure.ac
parent7d7610007aeb3e31e9d51996a2234659de792a25 (diff)
now user-guide.info is built only when "makeinfo" found
user-guide info is built only when "makeinfo" found Signed-off-by: Anand V. Avati <avati@amp.gluster.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4d90307023f..c5e0da84a8e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -134,6 +134,26 @@ AC_CANONICAL_HOST
AC_PROG_CC
AC_PROG_LIBTOOL
+# texinfo check
+AC_CHECK_PROG([INFO], [makeinfo], [yes], [no])
+if test "x$INFO" = "xno"; then
+ AC_MSG_WARN([
+*** Makeinfo is missing. Info documentation will not be built.])
+ BUILD_INFO=
+else
+ BUILD_INFO=user-guide
+ case "$INFO" in
+ */missing\ makeinfo*)
+ BUILD_INFO=
+ AC_MSG_WARN([
+*** Makeinfo is missing. Info documentation will not be built.])
+ ;;
+ *)
+ esac
+fi
+AC_SUBST(INFO)
+AC_SUBST(BUILD_INFO)
+
# LEX needs a check
AC_PROG_LEX
if test "x${LEX}" != "xflex" -a "x${FLEX}" != "xlex"; then