summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmmanuel Dreyfus <manu@netbsd.org>2012-03-30 15:58:43 +0200
committerAnand Avati <avati@redhat.com>2012-04-23 21:29:03 -0700
commit7313b22f10fafe7773a15d8306496d1d56ef5f81 (patch)
tree5080fcb607bbea24938444ef2eb5a031fee54793 /configure.ac
parent92baa61bfe5853fca301eb1e10f063097df24e2e (diff)
NetBSD build fixes
Signed-off-by: Emmanuel Dreyfus <manu@netbsd.org> Change-Id: I8f9aabeadd2f842521a82e59594115bd80155d68 BUG: 2923 Signed-off-by: Emmanuel Dreyfus <manu@netbsd.org> Reviewed-on: http://review.gluster.com/3053 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Anand Avati <avati@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ef3e122aa2e..36e9f08f342 100644
--- a/configure.ac
+++ b/configure.ac
@@ -394,6 +394,11 @@ dnl Linux, Solaris, Cygwin
AC_CHECK_MEMBERS([struct stat.st_atim.tv_nsec])
dnl FreeBSD, NetBSD
AC_CHECK_MEMBERS([struct stat.st_atimespec.tv_nsec])
+case $host_os in
+ *netbsd*)
+ CFLAGS=-D_INCOMPLETE_XOPEN_C063
+ ;;
+esac
AC_CHECK_FUNC([linkat], [have_linkat=yes])
if test "x${have_linkat}" = "xyes"; then
AC_DEFINE(HAVE_LINKAT, 1, [define if found linkat])
@@ -474,8 +479,9 @@ case $host_os in
if test "x$ac_cv_header_execinfo_h" = "xyes"; then
GF_GLUSTERFS_LDFLAGS="-lexecinfo"
fi
- GF_FUSE_LDADD="-liconv -lperfuse"
- BUILD_FUSE_CLIENT=no
+ GF_FUSE_LDADD="-lperfuse"
+ BUILD_FUSE_CLIENT=yes
+ LEXLIB=""
;;
*bsd*)
GF_HOST_OS="GF_BSD_HOST_OS"