summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRaghavendra Talur <rtalur@redhat.com>2015-03-10 15:13:29 +0530
committerNiels de Vos <ndevos@redhat.com>2015-04-13 05:38:24 +0000
commit3fc4f31a78e06dc09e03a958be500683dc9bcd78 (patch)
tree5673a430f77202ab4f8341526e512f917dab9e40 /configure.ac
parentd10bd788fada54ad095e19b5aedf949e23fdabb2 (diff)
configure.ac: print yes/no instead of 1/0 in output
POSIX_ACLS support in output of configure shows 0/1 instead of no/yes. Added BUILD_POSIX_ACLS to make value consistent. Change-Id: Ife728d0d03ff0eb03d4389fefc04507a76205ccd BUG: 1185654 Signed-off-by: Raghavendra Talur <rtalur@redhat.com> Reviewed-on: http://review.gluster.org/9848 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com> Reviewed-by: Niels de Vos <ndevos@redhat.com> Tested-by: NetBSD Build System
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9fe68e948f4..608d267a5a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -416,11 +416,13 @@ case $host_os in
AC_MSG_WARN([NetBSD does not support POSIX ACLs... disabling them])
ACL_LIBS=''
USE_POSIX_ACLS='0'
+ BUILD_POSIX_ACLS='no'
;;
*)
AC_CHECK_HEADERS([sys/acl.h], ,
AC_MSG_ERROR([Support for POSIX ACLs is required]))
USE_POSIX_ACLS='1'
+ BUILD_POSIX_ACLS='yes'
case $host_os in
linux*)
ACL_LIBS='-lacl'
@@ -1323,6 +1325,6 @@ echo "XML output : $BUILD_XML_OUTPUT"
echo "QEMU Block formats : $BUILD_QEMU_BLOCK"
echo "Encryption xlator : $BUILD_CRYPT_XLATOR"
echo "Unit Tests : $BUILD_UNITTEST"
-echo "POSIX ACLs : $USE_POSIX_ACLS"
+echo "POSIX ACLs : $BUILD_POSIX_ACLS"
echo "Data Classification : $BUILD_GFDB"
echo