summaryrefslogtreecommitdiffstats
path: root/booster/src/Makefile.am
diff options
context:
space:
mode:
authorShehjar Tikoo <shehjart@gluster.com>2009-06-25 14:31:27 +0000
committerAnand V. Avati <avati@dev.gluster.com>2009-06-29 10:42:04 -0700
commit76aa99422562a500c3b82cb826ce582576065a83 (patch)
tree65df73305affbe658fd8e70c8c4a2e7dbb26a8d4 /booster/src/Makefile.am
parent4fd96085c5a029e7be9e24e0c33b13268b290d6b (diff)
booster: Add new booster-specific fd-table
The reason we need a booster specific fd-table is because the libglusterfs fd-table has come to a point where it is optimized for libglusterfs-style of fd allocations. This conflicts with the way booster requires fds to be allocated so this commit brings in a re-based version of a booster-specific fd-table written by Raghu. Signed-off-by: Anand V. Avati <avati@dev.gluster.com>
Diffstat (limited to 'booster/src/Makefile.am')
-rw-r--r--booster/src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/booster/src/Makefile.am b/booster/src/Makefile.am
index 8202e795cfe..a5158591226 100644
--- a/booster/src/Makefile.am
+++ b/booster/src/Makefile.am
@@ -2,8 +2,8 @@ xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/performance
ldpreload_PROGRAMS = glusterfs-booster.so
ldpreloaddir = $(libdir)/glusterfs/
-noinst_HEADERS = booster_fstab.h
-glusterfs_booster_so_SOURCES = booster.c booster_stat.c booster_fstab.c
+noinst_HEADERS = booster_fstab.h booster-fd.h
+glusterfs_booster_so_SOURCES = booster.c booster_stat.c booster_fstab.c booster-fd.c
glusterfs_booster_so_CFLAGS = -I$(top_srcdir)/libglusterfsclient/src/ -D_GNU_SOURCE -D$(GF_HOST_OS) -fPIC -Wall \
-pthread $(GF_BOOSTER_CFLAGS)
glusterfs_booster_so_CPPFLAGS = -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE \