summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNiels de Vos <ndevos@redhat.com>2015-01-19 10:20:28 +0100
committerNiels de Vos <ndevos@redhat.com>2015-01-30 10:55:49 -0800
commitc46070189e4d9a71f7884dad06ee48b935c591e9 (patch)
tree679eaebbe78b5f89f3a448050dac0cc6a227aed4 /Makefile.am
parent64132200590a9310ea221524e13db8a09bd89313 (diff)
build: do not include automake/autoconf cache in the 'make dist' tarball
Remove the caches from the 'dist-hook' target that 'make dist' executes. Also, there is no need to run ./configure inside contrib/argp-standalone if it will not get used. configure.ac has been modified to only configure the contrib/argp-standalone sources for distributions that do not have the <argp.h> header available. BUG: 1183538 Change-Id: Iedd67139ec83f0076e24ed0d575f9053ac1a94ec Signed-off-by: Niels de Vos <ndevos@redhat.com> Reviewed-on: http://review.gluster.org/9463 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 187bfd5ed16..43926119fc0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,10 +29,15 @@ gitclean: distclean
-rm -f $(CONTRIBDIR)/argp-standalone/config.h.in
-rm -f $(CONTRIBDIR)/argp-standalone/configure
-rm -f $(CONTRIBDIR)/argp-standalone/depcomp
+ -rm -fr $(CONTRIBDIR)/argp-standalone/.deps
-rm -f $(CONTRIBDIR)/argp-standalone/install-sh
-rm -f $(CONTRIBDIR)/argp-standalone/missing
dist-hook: gen-VERSION gen-ChangeLog
+ -rm -fr $(distdir)/contrib/argp-standalone/autom4te.cache
+ -rm -fr $(distdir)/contrib/argp-standalone/.deps
+ -rm -fr $(distdir)/contrib/umountd/.deps
+
.PHONY: gen-VERSION gen-ChangeLog
gen-ChangeLog: