summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPrasanna Kumar Kalever <prasanna.kalever@redhat.com>2015-06-09 15:25:20 +0530
committerNiels de Vos <ndevos@redhat.com>2015-07-12 10:17:14 -0700
commitbfbd710b675d61fb3e8eaecd70eca92f806c6d8d (patch)
tree24de234e191fdb12ca7926b0cb71383c64ed0fad /Makefile.am
parent7f21238bb918a9b6eefcff5d76516a92a9271ae2 (diff)
build: fix gitclean target
$ make gitclean # deleting unexpected 'Makefile' files ... $ git status ... deleted: extras/FreeBSD/Makefile deleted: extras/command-completion/Makefile deleted: extras/test/ld-preload-test/Makefile ... This change fix to ignore above built-in makefiles while executing 'gitclean' target Change-Id: I5365f5a1fe5b36141a6fe7ba27c38a2158f9f3a3 BUG: 1229639 Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com> Reviewed-on: http://review.gluster.org/11136 Tested-by: Gluster Build System <jenkins@build.gluster.com> Tested-by: NetBSD Build System <jenkins@build.gluster.org> Reviewed-by: Niels de Vos <ndevos@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 900b5fe9796..5bfe07c4abf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,7 +25,9 @@ CONFIG_CLEAN_FILES = $(CONTRIB_BUILDDIR)/uuid/uuid_types.h
gitclean: distclean
find . -name Makefile.in -exec rm -f {} \;
- find . -name Makefile -exec rm -f {} \;
+ find . -name Makefile \( ! -path "$(top_srcdir)/extras/FreeBSD/*" \
+ ! -path "$(top_srcdir)/extras/command-completion/*" \
+ ! -path "$(top_srcdir)/extras/test/*" \) -exec rm -f {} \;
find . -name mount.glusterfs -exec rm -f {} \;
rm -fr autom4te.cache
rm -f missing aclocal.m4 config.h.in config.guess config.sub ltmain.sh install-sh configure depcomp