summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKaleb S KEITHLEY <kkeithle@redhat.com>2015-11-13 14:07:03 -0500
committerKaleb KEITHLEY <kkeithle@redhat.com>2015-11-15 03:02:32 -0800
commitb7b13c73369a3cb237de16d58425b63640c6f33e (patch)
tree444cffee83e53f12a2d8783f86df2e5e2bae7776 /Makefile.am
parent869b81fceabf3b9d5508665fc36fa7f98a4d4316 (diff)
build: `make distclean` doesn't clean all it ought to, needs to
Debian builds fail to "build twice in a row" due to left over files remaining after running `make distclean` The main culprits are files created from *.in files during ./configure. In particular these are ./glusterfs-api.pc, ./libgfchangelog.pc, ./libgfdb.pc, and ./tests/env.rc. The strange one is contrib/umountd/Makefile{,.in}. While these are created by ./configure - for reasons I don't quite fathom, perhaps because contrib/umountd is included in EXTRA_DIST - after that make and make distclean don't descend into the directory to build or clean it (because it's not needed for Linux, and not built.) Also removing the `find . -name Makefile -exec rm -f {}\;` from the gitclean target, it's not needed (redundant) as its prereq distclean target will have already removed them. Change-Id: Ifc45b71d852052ef4b92f356279ce2ba2bbc5bb6 BUG: 1279836 Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com> Reviewed-on: http://review.gluster.org/12579 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Milind Changire <mchangir@redhat.com> Tested-by: Milind Changire <mchangir@redhat.com> Reviewed-by: Niels de Vos <ndevos@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 5bfe07c4abf..1201ca2319b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,14 +20,12 @@ if USE_GFDB
pkgconfig_DATA += libgfdb.pc
endif
-CLEANFILES =
+CLEANFILES = glusterfs-api.pc libgfchangelog.pc libgfdb.pc \
+ tests/env.rc contrib/umountd/Makefile{,.in}
CONFIG_CLEAN_FILES = $(CONTRIB_BUILDDIR)/uuid/uuid_types.h
gitclean: distclean
find . -name Makefile.in -exec rm -f {} \;
- find . -name Makefile \( ! -path "$(top_srcdir)/extras/FreeBSD/*" \
- ! -path "$(top_srcdir)/extras/command-completion/*" \
- ! -path "$(top_srcdir)/extras/test/*" \) -exec rm -f {} \;
find . -name mount.glusterfs -exec rm -f {} \;
rm -fr autom4te.cache
rm -f missing aclocal.m4 config.h.in config.guess config.sub ltmain.sh install-sh configure depcomp