summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHarshavardhana <harsha@harshavardhana.net>2014-03-26 16:55:12 -0700
committerAnand Avati <avati@redhat.com>2014-04-04 21:52:10 -0700
commitb66568b6cb6694016f95e9d5a5220d3bde76907d (patch)
tree02dd9b7cf88a65cb4b3661fbce300c733c967ccc /Makefile.am
parentd8dd4049143c191cea451bade470b906c67dbbe0 (diff)
build: move argp-standalone into contrib/ directory
Change-Id: Iedcddf95c3577da644c0aebbb297b04c93f1b6fe BUG: 1081274 Signed-off-by: Harshavardhana <harsha@harshavardhana.net> Reviewed-on: http://review.gluster.org/7352 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Anand Avati <avati@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 598ebb4103c..fa0f52ea144 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,7 @@ EXTRA_DIST = autogen.sh \
gen-headers.py run-tests.sh \
$(shell find $(top_srcdir)/tests -type f -print)
-SUBDIRS = argp-standalone libglusterfs rpc api xlators glusterfsd \
+SUBDIRS = contrib/argp-standalone libglusterfs rpc api xlators glusterfsd \
$(FUSERMOUNT_SUBDIR) doc extras cli @SYNCDAEMON_SUBDIR@
pkgconfigdir = @pkgconfigdir@
@@ -20,10 +20,13 @@ gitclean: distclean
find . -name mount.glusterfs -exec rm -f {} \;
rm -fr autom4te.cache
rm -f missing aclocal.m4 config.h.in config.guess config.sub ltmain.sh install-sh configure depcomp
- rm -fr argp-standalone/autom4te.cache
- rm -f argp-standalone/aclocal.m4 argp-standalone/config.h.in
- rm -f argp-standalone/configure argp-standalone/depcomp
- rm -f argp-standalone/install-sh argp-standalone/missing
+ rm -fr $(CONTRIBDIR)/argp-standalone/autom4te.cache
+ rm -f $(CONTRIBDIR)/argp-standalone/aclocal.m4
+ rm -f $(CONTRIBDIR)/argp-standalone/config.h.in
+ rm -f $(CONTRIBDIR)/argp-standalone/configure
+ rm -f $(CONTRIBDIR)/argp-standalone/depcomp
+ rm -f $(CONTRIBDIR)/argp-standalone/install-sh
+ rm -f $(CONTRIBDIR)/argp-standalone/missing
dist-hook:
(cd $(srcdir) && git diff && echo ===== git log ==== && git log) > $(distdir)/ChangeLog