summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAnand Avati <avati@redhat.com>2013-09-15 19:56:25 -0700
committerAnand Avati <avati@redhat.com>2013-09-20 21:12:39 -0700
commit7f608415063f04a1035bfe7d0f8ddfb9f0215e5c (patch)
tree547deabfc9053525165b1d9719640f715aac0e24 /Makefile.am
parent2e4064fe08e929fb4db30ae63c5cd404ab2d8b20 (diff)
tests: take regression tests out of autotools
make run-tests.sh "location independent" and replace 'make install' with cpio in glusterfs.spec.in Change-Id: I140473c7f558e1e0af93a863b79098ced516a76b BUG: 764966 Signed-off-by: Anand Avati <avati@redhat.com> Reviewed-on: http://review.gluster.org/5986 Reviewed-by: Harshavardhana <harsha@harshavardhana.net> Tested-by: Gluster Build System <jenkins@build.gluster.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 2210492db86..598ebb4103c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,11 +1,10 @@
-include $(top_srcdir)/tests.mk
-
EXTRA_DIST = autogen.sh \
COPYING-GPLV2 COPYING-LGPLV3 \
INSTALL README AUTHORS THANKS NEWS \
glusterfs.spec glusterfs-api.pc.in libgfchangelog.pc.in \
error-codes.json gf-error-codes.h.template \
- gen-headers.py
+ gen-headers.py run-tests.sh \
+ $(shell find $(top_srcdir)/tests -type f -print)
SUBDIRS = argp-standalone libglusterfs rpc api xlators glusterfsd \
$(FUSERMOUNT_SUBDIR) doc extras cli @SYNCDAEMON_SUBDIR@