summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAnand Avati <avati@redhat.com>2012-11-26 20:02:18 -0800
committerAnand Avati <avati@redhat.com>2012-11-30 00:00:39 -0800
commit692c0e98da8613c004f24ccf7084fc517ba8b4e4 (patch)
tree56b571b00399af895ed697e791414124ce0992a5 /Makefile.am
parenta20b52d029cc98e4ffdb4d6b187e02ffdfcc9137 (diff)
build: make dist to capture current build tree state
ChangeLog will now hold the 'git log' and 'git diff' against the HEAD of the tree from which 'make dist' was issued. Change-Id: I0b5b27de66b02d733612470a8c79d65f0b560fa1 BUG: 764890 Signed-off-by: Anand Avati <avati@redhat.com> Reviewed-on: http://review.gluster.org/4235 Reviewed-by: Amar Tumballi <amarts@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 836f17efc1b..5f3cf322dac 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,3 +19,7 @@ gitclean: distclean
rm -f missing aclocal.m4 config.h.in config.guess config.sub ltmain.sh install-sh configure depcomp
rm -fr argp-standalone/autom4te.cache
rm -f argp-standalone/aclocal.m4 argp-standalone/config.h.in argp-standalone/configure argp-standalone/depcomp argp-standalone/install-sh argp-standalone/missing
+
+dist-hook:
+ sh -c "cd $(srcdir) && git diff && echo ===== git log ==== && git log" \
+ > $(distdir)/ChangeLog