summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDmitry Antipov <dmantipov@yandex.ru>2020-08-14 13:47:13 +0300
committerAmar Tumballi <amar@kadalu.io>2020-08-19 04:27:56 +0000
commit2b7455fe833e3dcb281030108bb2f97d4a220b26 (patch)
tree46461aa5a7f4b07c8b02fd55a97d06a754e753d5 /Makefile.am
parent5af2c685ed3d33290ceac5aa229efec8bba127e6 (diff)
build: add custom clean rules
Make 'clean' and 'gitclean' even more cleaner by removing extra build leftovers. Change-Id: I9c261e1f029b8486f328aaa330f0476d44b58eac Signed-off-by: Dmitry Antipov <dmantipov@yandex.ru> Updates: #1002
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index aa0ca5c2a04..98ea5c1038d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,9 +19,13 @@ pkgconfig_DATA = glusterfs-api.pc libgfchangelog.pc
CLEANFILES = glusterfs-api.pc libgfchangelog.pc contrib/umountd/Makefile
+clean-local:
+ find . -name '*.o' -o -name '*.lo' -o -name '.Po' | xargs rm -f
+
gitclean: distclean
find . -name Makefile.in -exec rm -f {} \;
find . -name mount.glusterfs -exec rm -f {} \;
+ find . -name .deps -o -name .libs | xargs rm -rf
rm -fr autom4te.cache
rm -f missing aclocal.m4 config.h.in config.guess config.sub ltmain.sh install-sh configure depcomp
@@ -49,4 +53,3 @@ gen-VERSION:
./build-aux/pkg-version --full \
> $(abs_top_builddir)/$(distdir)/VERSION; \
fi
-