summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAmar Tumballi <amarts@redhat.com>2018-10-03 17:00:24 +0530
committerAtin Mukherjee <amukherj@redhat.com>2018-11-02 02:39:35 +0000
commit55a6ba56bea9ec0d3316c005300c514ea3ab0e54 (patch)
tree0d36d876e25b158858805b682d01bb5207a4f08e /Makefile.am
parent6e8f7bb6ab457cfee42e405243cf4db82a9a56b8 (diff)
tiering: remove the translator from build and glusterd
Based on the proposal to remove few features as they are not actively maintained [1], removing tier translator from the build. Also make sure there are no regression tests involving tiering feature are present. [1] https://lists.gluster.org/pipermail/gluster-users/2018-July/034400.html Change-Id: I2c177f711f9b54b7b24e1a13525ff3132bd9a9c5 updates: bz#1642807 Signed-off-by: Amar Tumballi <amarts@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 2 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 613382f9809..e0c795f418f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,7 +3,7 @@ SOURCES = site.h
EXTRA_DIST = autogen.sh \
COPYING-GPLV2 COPYING-LGPLV3 COMMITMENT \
INSTALL README.md AUTHORS THANKS NEWS \
- glusterfs.spec glusterfs-api.pc.in libgfchangelog.pc.in libgfdb.pc.in \
+ glusterfs.spec glusterfs-api.pc.in libgfchangelog.pc.in \
run-tests.sh \
build-aux/pkg-version \
contrib/umountd \
@@ -15,12 +15,8 @@ SUBDIRS = $(ARGP_STANDALONE_DIR) rpc/xdr/gen libglusterfs rpc api xlators \
pkgconfigdir = @pkgconfigdir@
pkgconfig_DATA = glusterfs-api.pc libgfchangelog.pc
-if USE_GFDB
-pkgconfig_DATA += libgfdb.pc
-endif
-CLEANFILES = glusterfs-api.pc libgfchangelog.pc libgfdb.pc \
- contrib/umountd/Makefile
+CLEANFILES = glusterfs-api.pc libgfchangelog.pc contrib/umountd/Makefile
gitclean: distclean
find . -name Makefile.in -exec rm -f {} \;