summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKaleb S. KEITHLEY <kkeithle@redhat.com>2015-05-29 13:47:14 -0400
committerKaleb KEITHLEY <kkeithle@redhat.com>2015-05-31 15:14:59 -0700
commit7023870b28b1eb87fb6eca2904c72e91fdcaf625 (patch)
tree73842ab99a9bff5d106b3996b7d1ac44feb1628c /Makefile.am
parent894a517a12411c4dfbdeda6b9e90df26f5855d2e (diff)
build: outdated autotools helper config.* files in dist tarfile
Our jenkins release task clones the source, runs ./autogen.sh (where config.{guess,sub} come from) and ./configure, before running `make dist` to product the release glusterfs-X.Y.Z.tar.gz. The config.{guess,sub} in the tar file come from the archaic autoconf in CentOS 6.3, which is what the glusterfs jenkins is running on. We should not be shipping the (arbitrary, old) config.{guess,sub} files from our jenkins machine. Change-Id: Ib7643ae2e54d0e25c95f4e93e5dffb22cbe11523 BUG: 1223937 Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com> Reviewed-on: http://review.gluster.org/11009 Reviewed-by: Niels de Vos <ndevos@redhat.com> Tested-by: Gluster Build System <jenkins@build.gluster.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 82175ee7ea9..1282c981d53 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -41,6 +41,7 @@ dist-hook: gen-VERSION gen-ChangeLog
-rm -fr $(distdir)/contrib/argp-standalone/autom4te.cache
-rm -fr $(distdir)/contrib/argp-standalone/.deps
-rm -fr $(distdir)/contrib/umountd/.deps
+ -rm -fr $(distdir)/config.{guess,sub}
.PHONY: gen-VERSION gen-ChangeLog