summaryrefslogtreecommitdiffstats
path: root/xlators/protocol/transport/ib-verbs/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/protocol/transport/ib-verbs/src/Makefile.am')
-rw-r--r--xlators/protocol/transport/ib-verbs/src/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/xlators/protocol/transport/ib-verbs/src/Makefile.am b/xlators/protocol/transport/ib-verbs/src/Makefile.am
new file mode 100644
index 00000000..8f6e6a35
--- /dev/null
+++ b/xlators/protocol/transport/ib-verbs/src/Makefile.am
@@ -0,0 +1,19 @@
+# TODO : need to change transportdir
+
+transport_LTLIBRARIES = ib-verbs.la
+transportdir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/transport
+
+ib_verbs_la_LDFLAGS = -module -avoidversion
+
+ib_verbs_la_SOURCES = ib-verbs.c name.c
+ib_verbs_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la \
+ -libverbs $(top_builddir)/xlators/protocol/lib/src/libgfproto.la
+
+noinst_HEADERS = ib-verbs.h name.h
+
+AM_CFLAGS = -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -Wall -D$(GF_HOST_OS) \
+ -I$(top_srcdir)/libglusterfs/src -shared -nostartfiles $(GF_CFLAGS) \
+ -I$(top_srcdir)/xlators/protocol/transport/ib-verbs \
+ -I$(top_srcdir)/xlators/protocol/lib/src
+
+CLEANFILES = *~