summaryrefslogtreecommitdiffstats
path: root/xlators/protocol/auth/addr/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/protocol/auth/addr/src/Makefile.am')
-rw-r--r--xlators/protocol/auth/addr/src/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/xlators/protocol/auth/addr/src/Makefile.am b/xlators/protocol/auth/addr/src/Makefile.am
index ebf20b38..7f1dd744 100644
--- a/xlators/protocol/auth/addr/src/Makefile.am
+++ b/xlators/protocol/auth/addr/src/Makefile.am
@@ -4,9 +4,8 @@ authdir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/auth
addr_la_LDFLAGS = -module -avoidversion
addr_la_SOURCES = addr.c
-addr_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la \
- $(top_builddir)/xlators/protocol/lib/src/libgfproto1.la
+addr_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
AM_CFLAGS = -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -Wall -D$(GF_HOST_OS)\
-I$(top_srcdir)/libglusterfs/src -shared -nostartfiles $(GF_CFLAGS) \
- -I$(top_srcdir)/xlators/protocol/lib/src
+ -I$(top_srcdir)/xlators/protocol/server/src