summaryrefslogtreecommitdiffstats
path: root/xlators/features/glupy/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/features/glupy/src/Makefile.am')
-rw-r--r--xlators/features/glupy/src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/xlators/features/glupy/src/Makefile.am b/xlators/features/glupy/src/Makefile.am
index 931e5b74..96086283 100644
--- a/xlators/features/glupy/src/Makefile.am
+++ b/xlators/features/glupy/src/Makefile.am
@@ -9,11 +9,11 @@ glupy_PYTHON = gluster.py negative.py helloworld.py debug-trace.py
glupy_la_LDFLAGS = -module -avoid-version -shared -nostartfiles
glupy_la_SOURCES = glupy.c
glupy_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la \
- -lpthread -lpython2.6
+ -lpthread -l$(BUILD_PYTHON_LIB)
noinst_HEADERS = glupy.h
-AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src
+AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src -isystem $(BUILD_PYTHON_INC)
AM_CFLAGS = -Wall -fno-strict-aliasing -DGLUSTER_PYTHON_PATH=\"$(glupydir)\" $(GF_CFLAGS)