summaryrefslogtreecommitdiffstats
path: root/extras/init.d/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'extras/init.d/Makefile.am')
-rw-r--r--extras/init.d/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/extras/init.d/Makefile.am b/extras/init.d/Makefile.am
index 66849af8..da9bb007 100644
--- a/extras/init.d/Makefile.am
+++ b/extras/init.d/Makefile.am
@@ -7,9 +7,11 @@ initdir = /etc/init.d
$(GF_DISTRIBUTION):
$(mkdir_p) $(DESTDIR)$(initdir)
- cp glusterfsd-$(GF_DISTRIBUTION) $(DESTDIR)$(initdir)/glusterfsd
+ $(INSTALL_PROGRAM) $(srcdir)/glusterfsd-$(GF_DISTRIBUTION) $(DESTDIR)$(initdir)/glusterfsd
-install-data-local: $(GF_DISTRIBUTION)
+install-exec-local: $(GF_DISTRIBUTION)
+
+install-data-local:
if GF_DARWIN_HOST_OS
cp glusterfs-server.plist /Library/LaunchDaemons/com.zresearch.glusterfs.plist
endif